Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Occasionally, I get part of an application lingering behind on my desktop:

alt text

This is part of a context menu for an application. It is always top-most, meaning that it is always on the screen, and I cannot click on it (it just clicks through it). It has happened before, sometimes with whole windows. It remains on screen even if the application it originated from is no longer running.

How do I get rid of it without rebooting?

share|improve this question
    
    
nice question! It is really annoying too on Windows7! –  Junior Mayhé Nov 21 '10 at 18:38
    
I've added a new answer - a little late in the day but I can confirm that it does fix it (in Windows7 at least). –  Ian Feb 21 at 9:03

5 Answers 5

up vote 6 down vote accepted

I've found a really easy hack to get rid of context menu phantoms like what you describe. Simply go into your screen resolution settings and change to a different resolution, then change back. The change of resolution seems to reset stuff at a lower level than where the phantom exists, which means the phantom gets cleaned up during the resolution change.

share|improve this answer
    
awesome hack, but it doesnt stop appearing them. –  csomakk Aug 6 '13 at 9:08
    
This will only resolve the current floating item - it won't stop the problem. –  Ian Feb 21 at 9:02

I've seen this behaviour with certain video cards.

Upgrade your video card driver. If that doesn't work or you can't upgrade it, you can dial down the acceleration on the video card. Go to the Advanced system Properties (Advanced tab) and in performance options, either reduce the level of acceleration or untick "Fade or slide menus into view"

share|improve this answer

The problem is caused by Aero, but there's an easy way to stop it.

  1. Right click “Computer” and select “Properties”.
  2. Click “Advanced System Settings”
  3. Click “Settings” in the “Performance” section
  4. Uncheck “Fade out menu items after clicking”

To remove any existing floating windows open up task manager and kill the dwm.exe process (Desktop Window Manager).

You shouldn't encounter the problem after this point.

share|improve this answer

Open cmd.exe as an administrator and type:

net stop uxsms

The ghosts are gone so you can leave it like that, but if you want you can re-start service
so then type:

net start uxsms

you can also add it as Desktop and Explorer Context Menu:

Add “Restart uxsms” Option in Desktop and Explorer Context Menu under Windows Vista and 7

share|improve this answer
1  
I'm confused... he should type net stop uxsms twice? –  Andrew Schulman Jan 12 at 12:38
    
net stop uxsms and then net start uxsms –  Jeson Park Feb 21 at 9:07

When this happens to me, it sometimes helps to switch back to the application to which this popup belongs. Then switch back to the application I want to use in the forgeround.

Most of the times, the popup then disappears.

share|improve this answer
    
The application it came from is no longer running. –  adrianbanks Jun 10 '10 at 11:39
    
Oh, okay. Maybe you can use the task manager to terminate explorer. Usually, it will be restarted automatically after termination. But I don't know if this has negative side-effects. You should save and close opened documents at any rate. –  Martin Jun 10 '10 at 13:43
1  
No, that doesn't work either. The only thing that seems to get rid of it is killing the desktop window manager (dwm.exe), but this then makes things paint very strangely on the screen and I end up having to reboot. –  adrianbanks Jun 10 '10 at 23:37
    
Okay, I see everything's resolved, but I'd like to add (for further info) that there's no problem in stopping explorer.exe, and you don't even need to save everything. if it doesn't start again automatically, you can start Task Manager, and in the first tab, right-click anywhere, and click the only option. Key in 'explorer.exe' without the quotations and you're done. You can run explorer again. –  Antrikshy Sep 6 '10 at 12:14

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.