Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

It seems the haunted keyboard is back in VS2010 ... after working on a web application for a short while I find that some keys just don't work, or are behaving like certain keys are stuck. This is only in VS, and I am definitely not triggering any keyboard changes in VS or Windows (I have disabled that in Windows) and I have reset my environment settings several times.

Aargh! This is so frustrating ... anyone else getting this problem? Is there a solution?

share|improve this question

migrated from stackoverflow.com Jun 10 '10 at 16:05

This question came from our site for professional and enthusiast programmers.

2  
Although the software is programming related, this question is not. It should probably be on superuser.com –  Callum Rogers Jun 8 '10 at 22:56
    
Roger that ... my apologies I guess I'm grasping at straws –  Ryan Jun 8 '10 at 23:05
    
You may also want to inform us of the addins you have installed. I have R#5 and JustCode and my keyboard has no issues with VS2010 –  Wayne Jun 8 '10 at 23:07
    
No add-ins, it is a fresh install as of 2 days ago. –  Ryan Jun 8 '10 at 23:09
1  
Maybe your problem is related to this bug on msdn? Does your problem go away after you hit ctrl-tab two times? –  kalyfe Jun 1 '11 at 7:53

2 Answers 2

It's your OS language setting. I had the same problem, and once I deleted my "English (Canada)" language in control panel, VS started working fine again.

share|improve this answer
    
Oh Canada! When will you ever learn. –  ta.speot.is Oct 3 '10 at 20:46

I can't say i've had this issue or seen other with this issue in Visual Studio 2010 but the following advice seems to have worked for Visual Studio 2005 users:

  1. Delete the "Visual Studio 2010" folder in My Documents. (MAKE A BACKUP FIRST THOUGH AS THIS WILL CONTAIN YOUR PROJECT DATA & CODE)

  2. Delete the "VisualStudio\10.0" folder in your Local and Roaming AppData folders (AGAIN MAKE BACKUPS)

  3. Remove any registry entries to do with Visual Studio 2010 (Visual Studio 10.) - AND ONCE AGAIN MAKE A BACKUP

  4. On the menubar click Tools -> Settings -> Import and Export Settings... This will bring up the Import and Export Settings Wizard and you can select the Reset all settings option.

Please keep in mind that I myself havn't actually performed these action myself and that this advice was actually originally given as a temporary fix for the haunted keyboard issue in Visual Studio 2005.

share|improve this answer
    
I think it would be "Import and Export Settings...", not "Important and Export Settings..." –  icktoofay Jun 8 '10 at 23:14
    
Thanks, you're right. It was just a typo and i've now edited it. –  Anonymous Jun 9 '10 at 13:30

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.