Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

NIC seems to be working, as windows detects the hardware and has a driver and reports success. DHCP seems to have gotten an ip address, 192.168.1.101. I released and renewed it and it seemed to work normally.

Edit: It's a Broadcom NetXtreme 57xx Gigabit Controller. /Edit

Edit: I can ping 192.168.1.101 (the offending machine) from other machines on the network, so I know the NIC is not broken. /Edit

Edit: Uninstalled/reinstalled NIC in device manager, nothing different. /Edit.

I tried ping 127.0.0.1 as first step of testing network configuration. Pinging 127.0.0.1 with 32 bytes of data: PING: transmit failed, error code 1.

I read somewhere that net helpmsg [error code] would give a human readable name for the error code. net helpmsg 1 says "Incorrect function"

I've tried disabling the firewall and antivirus in McAfee SecurityCenter and I still get the same error. Could the firewall/antivirus be breaking it even if disabled?

Broadcom Advanced Control Suite 2 is installed, and its network test passes all tests, including ping 192.168.1.1 which is the default gateway. If I try ping 192.168.1.1 from the command prompt I get the error code 1 again.

So does anyone have any theories that would explain this problem? Other tests I should try?

Thanks!

share|improve this question
    
This is a computer I'm fixing for a friend who fixed an electrical problem on my motorcycle. Now that his pc is working again I can get him to help me change the final drive ratio. Working pc == working motorcycle! –  Mnebuerquo Jun 10 '10 at 17:33

3 Answers 3

up vote 2 down vote accepted

The McAfee program was lying to me. I told it to disable the firewall and antivirus, but it was still blocking programs from accessing the internet. So when I tried ping with the firewall supposedly turned off, ping still failed.

The answer is to look at the Internet Application List under Personal Firewall Plus in the Security Center. There will be a list of programs which have used the internet and whether they are blocked or allowed.

Among the blocked programs were Internet Explorer and ping.exe. Changing the incorrectly blocked programs back to allowed fixed the problems.

The real problem was McAfee's program reporting that their firewall was disabled when it was still blocking access. This cost me over 4 hours and a headache today. Thanks McAfee!

share|improve this answer

Have you tried re-installing the TCP/IP stack? Have you checked to make sure your ping.exe is not infected?

share|improve this answer

If there is a firewall on the pc than it may be preventing ping. I'd disable any security software for the duration of the test. I'd also check the status of the NIC in device manager, just to make sure there are no driver errors

share|improve this answer
    
NIC is fine, because 127.0.0.1 does not even reach it. –  grawity Jun 10 '10 at 16:47
    
I agree, however, there was a known problem a while back with the XP built in firewall that caused this error. Hence the suggestion. –  Pulse Jun 10 '10 at 17:15
    
That's why I suspected McAfee and tried to disable their firewall. –  Mnebuerquo Jun 10 '10 at 17:29
    
@Mnebuerquo Disabling only sets the firewall to "allow everything". It does not reset networking settings, does not remove the McAfee's filter drivers. Only a complete uninstall would. –  grawity Jun 10 '10 at 20:50
    
@grawity: Allow everything should allow ping and other programs access to the network. When I did tell it to disable the firewall, those programs were still blocked. –  Mnebuerquo Jun 12 '10 at 17:29

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.