Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am new to Linux, so even though this is probably a simple problem it remains unsolved after more then 3 hours of googling.

I am run running Ubuntu 10.04 LTS on an Acer Aspire 5520G. The laptop has a wireless adapter, but since I wanted better range I got an Edimax EW-7711USN USB adapter. Now, when running ifconfig, I am able to see both adapters. The laptop native adapter is listed as wlan0 and the usb adapter is listed as wlan1.

But listing available networks from the wireless network applet, all the connections are listed under wlan0. The USB adapter is consistently listed as disconnected. This is what I have been trying to do so far:

  1. ifconfig wlan0 down - I got disconnected from the net but still was not able to get the USB to connect.
  2. Used the wireless connection dialog to connect to a hidden network with the USB adapter - I was able to connect to the network but with no Internet access.
  3. Disabled wireless using the laptop function button - both wireless adapters were disabled.

Can anyone suggest a way to connect to to the wireless network using the USB adapter rather then the built-in adapter?

Thanks

share|improve this question

2 Answers 2

This should also work for Ubuntu:

http://wiki.archlinux.org/index.php/Beginners'_Guide#Wireless_Quickstart_For_the_Live_Environment_.28If_you_need_wireless_connectivity_during_the_installation_process.29

share|improve this answer
    
the link points to limbo :-( –  James Jun 10 '10 at 20:51
1  
wiki.archlinux.org/index.php/… –  Kevin Panko Jun 10 '10 at 21:01

Did you try a different network manager like Wicd? As far as I know, this one allows you to say which adapter you want to use in its preferences.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.