Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Consider a Windows 7 64-bit host where the VirtualBox guest is configured to use Bridged Adapter.

An exception is raised when starting this guest machine:

Failed to open/create the internal network HostInterfaceNetworking (VERR_SUPDRV_COMPONENT_NOT_FOUND)

Result Code: E_FAIL (0x80004005)

What resolution is there to this problem for Bridged Adapters in VirtualBox?

The solutions attempted:

  • changed Adapter Type to all available choices. No changes.
  • uninstall VirtualBox, reboot host, re-install VirtualBox. No change in behaviour.
  • edited the machine's .xml file, wiping out all <Network> <Adapter> nodes. Had VirtualBox re-create those nodes. No change.
  • creating brand new guests shows no different behaviour; still receive this error.
  • multiple-of-8 as the RAM allocated to the guest (differing from this screenshot).

alt text

alt text

Host Details

  • Oracle VirtualBox 4.0.12
  • Windows 7 64-bit
  • Windows Firewall is turned off on the host.

enter image description here

C:\Program Files\Oracle\VirtualBox\drivers\network\netflt.inf

share|improve this question

4 Answers 4

up vote 3 down vote accepted

The thread Bridged Adapter problem suggests that the problem is the network MaxNumFilters limit in Windows.

By default, the MaxNumFilters value is 8. You can change it up to 14, using regedit in this location:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Network, value of MaxNumFilters.

Note: If you don't see MaxNumFilters, you can create it with the Type of REG_DWORD as shown below :

image

If after this change you still have the problem, then while leaving the value of MaxNumFilters as 14, uninstall VirtualBox, reboot, then reinstall it.

share|improve this answer

Been there done that, the solution is to remove the relevant network devices from the device manager.

This will cause them to be detected again, reinstalled with proper registry keys, and thus function properly again. If not, reinstall VBox...

share|improve this answer
    
This works perfect for me :-) –  michel Apr 22 at 11:57

Update / Answer: Reinstall VirtualBox with the latest version, (currently 4.1.2). To do this, download the latest and simply run the install - make sure you do 2 things: (1) make sure you do it as an Administrator ("Run as Administrator") and (2) agree to install all of the drivers asked by UAC / Oracle.


Is this on a fresh / new instance, or are you trying to import one from an older version of VirtualBox or another host?

What if you create a new Virtual Machine through the VirtualBox UI (without touching the XML files please), do you still have this problem?

Did you make sure to allow VirtualBox in your Windows Firewall? Try disabling your Firewall completely to check, temporarily of course.

Possibly unrelated: I noticed that the RAM is set to something other than a multiple of 8. My experience has been that this causes some weird issues with VirtualBox so it's best to stick with 256MB, 512MB, 768MB, etc.

share|improve this answer
    
Updated my answer. –  Joshua Sep 15 '11 at 21:19

I've not been successful using Bridged adapters in VB4/Windows7. I get along with the NAT adapter, and it has 0 issues. This is on a Mac, but I think the issue lays with VB, not the native host. I have tried ALL the NIC combos, to little avail. Go with NAT... it's not worth torn hair.

share|improve this answer
    
Thanks alex - I guess I should've stated up front -- the reason I'm wanting this is to be able to Remote Desktop into the guest. –  p.campbell Sep 15 '11 at 22:01
    
You still can.... Just map the port! Or try out one of the many utilities/services/software/hardware that will traverse your NAT for you... –  mralexgray Sep 15 '11 at 23:10

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.