Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Every time I run this legacy program I get the UAC popping up. It's really anoying, is there a way to disable it just for this one program rather than my whole system? I need the UAC to be active for most programs because I do development and testing on this system.

share|improve this question

2 Answers 2

up vote 1 down vote accepted

If it pops up every time you run the program, than the program is set to always run with administrator rights (Right click on executable -> Properties -> Compatibility)

You can stop the UAC from popping up by disabling this. However, if the program needs perform administrator actions, I'm afraid you're out of luck. You might try turning down the level of UAC which might make it ignore the program and elevate regardless (might), or if the program only needs to access administrator-only files, then give yourself full control over those files and disable the always-run-as-admin.

share|improve this answer
    
Yep, this is likely what's causing it. Furthermore, consider that the ability to disable UAC for a specific program would defeat the purpose of UAC. If programs could be set to always run at an elevated level without prompting, it would offer a huge security vulnerability. You would be better off figuring out why it needs compatibility access, and adjust local permissions accordingly so it doesn't need to be elevated. Often all a program needs is to have access to its directory in %programfiles% or something similar. –  nhinkle Jun 11 '10 at 3:31
    
I had XP Compatiblity mode turned on which it needs. Security isn't an issue really. I just wanted UAC to know how users would see the program when I'm testing it. I'm gona remove UAC completely. –  Daisetsu Jun 11 '10 at 22:21
    
@nhinkle i think he means disabling UAC for one program, meaning that the program will run as a standard user (i.e. the opportunity to temporarily elevate to administrator is disabled, so i stay as standard user) –  Ian Boyd Mar 26 '12 at 17:10

The How-to geek has a work-around that involves the task scheduler. This lets you create a short-cut for running a program in administrator mood, without prompting you. See this page.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.