Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I turn on my TV, it's often the case that the screen is blank and I have to unplug / plug the HDMI cable connected from the Windows Media Center to a Samsung LED TV.

This problem only occurs when the Media Center has played content that contains HDCP data (which is the case if you are using an ATI Digital Cable Tuner or OCUR device).

The card is an ATI HD4550 and the OS is Windows 7.

share|improve this question
    
also having the same issue superuser.com/questions/2093 but with ATI Radeon HD 3200. –  Scott Weinstein Aug 17 '09 at 14:05

4 Answers 4

Have you tried pressing ctrl+alt+del?

I had a similar problem under Vista Media Center with the HDMI connector, and that always seemed to work.

share|improve this answer
    
ctrl+alt+del is not wife friendly –  Omar Shahine Aug 3 '09 at 16:20
    
I agree, but I'm curious -- does it work? –  Jeff Atwood Aug 3 '09 at 16:44
    
having the same issue too, I'll try this as well, but I'm wondering if it's possible to a a ctrl+alt+del from a remote control? –  Scott Weinstein Aug 17 '09 at 14:00
1  
yes, it does work. So does alt-f4 to quit the Media Center shell. –  Omar Shahine Aug 24 '09 at 5:18
1  
Scott, what you can do is what I have done which is configure a program called Intelliremote (melloware.com/products/intelliremote) to send key commands and map them to Media Center keys like the red / yellow / blue / green custom buttons. –  Omar Shahine Aug 24 '09 at 5:19

Couple things/questions you can try to isolate the problem, if you have not already tried the following.

  1. Does this behavior occur on another LED or LCD?

    • Try using another LED or LCD to see if you can isolate this behavior to the PC.

  2. Are you using a DVI to HDMI converter?

    • Not sure what type of ATI HD4550 card you have, but they appear to have only DVI and VGA connectors which leads me to believe you're using a DVI to HDMI converter. - It's possible that the DVI to HDMI converter is damaged. Try using another DVI to HDMI converter.

  3. Was this computer a custom build PC (not through a certified CableCard dealership)?

    • If this is not a custom build PC, I would check with the builder/site of the PC to see if they have any updated drivers or BIOS updates for your PC model.

  4. Does your ATI HD4550 card have Windows 7 certified drivers?

    • I'd check to make sure you have the latest/updated drivers for your graphics card and tuner cards.

As these are just starting suggestions, I'm sure you have tried at least some of these but one can never know :-) good luck !!!

share|improve this answer
up vote 1 down vote accepted

Ok, here is a solution that works 100% of the time for me.

1) Buy an HDMI Detective Plus

This gadget basically gets programmed with your TV's EDID and then fakes your Media Center into thinking the TV is on 24/7. Genius

2) Go the software route

Prerequisites

  1. Harmony Remote (Logitech)
  2. HDMIOn.exe

First, you need to ensure that you get the latest Media Center remote configuration file for your Harmony Remote. You can find this device under

Device type: Computer -> Media Center 
PC Manufacturer: Microsoft 
Model: Windows Media Center SE

and includes the ability to send Media Center keyboard commands such as Win+1, ALT+1 etc

Then you need to configure the Activity for your Media Center "Watch TV" action to include an additional remote command, which is to send Media Center a custom keyboard shortcut. Since I am using Windows 7 I selected Win+1 to launch the first item in my taskbar

Now you need to download HDMIOn.exe and place it somewhere on your Hard Drive and then pin in to the TaskBar in the corresponding location that you are using for the shorcut.

Alternativley you can create a shortcut for HDMIOn.exe and assign a shortcut key like ALT+1 to that shortcut.

Now when you press the Watch TV Activity on your Harmony remote, the HDMIOn.exe app will launch causing your HDMI handshake to get resent.

share|improve this answer

I would check o make sure the power saving features are all turned off on your display settings in the control panel. Some devices are not smart enough to wake back up in the same manner that a monitor on a computer does.

share|improve this answer
1  
I tried that to no avail. I disabled placing the display to sleep and no dice. –  Omar Shahine Aug 2 '09 at 17:45

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.