Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have Ubuntu 10.04 dual booted with Windows Vista on a work Lenovo R61 laptop. The home and work wireless connection were working fine. I lost all internet connection at work. The IT guy clearly knew nothing about Linux. Since he 'fixed' it, I get nothing, no WLAN signal the Network Manager icon was gone, no internet. I still have the live disc and if I run from the live disc the connections are there and everything works perfectly. How do I restore the internet easily on my laptop? I have been using Linux for 3 years but I am still a bit of a newbie, this is the first major problem I've had in three years. It's driving me nuts.

Thanks

share|improve this question
    
Output of ifconfig -a and iwconfig -a would be nice to see. –  Bobby Jun 11 '10 at 10:11
    
Don't be too hard on your IT guy. In most workplaces, your dual-boot Ubuntu/Windows system is not a supported configuration, and any customizations are your responsibility. –  Stefan Lasiewski Jun 12 '10 at 3:59
    
Also, you recently updated to Ubuntu 10.4. Has this worked since you upgraded? –  Stefan Lasiewski Jun 12 '10 at 4:01

3 Answers 3

To start, lets see what happens when you re-install network-manager. You can find it under Applications -> Ubuntu Software Center -> then search for network manager.

Edit:

Ok... well... slight brain fart. Once you uninstall network manager... you still won't have Internet in order to download and install it again.

You can either try downloading the network manager .deb file from another computer and then copying it over from a thumb drive or you can check the /var/cache/apt/archives as descrived here in order to reinstall it. The only network related package I found in that directory however was libqt4-network_4%3a4.6.2-0ubuntu5_amd64.deb. Not sure if that is what you need.

share|improve this answer
    
It is telling me it is an invalid command? –  Keeper780 Jun 11 '10 at 21:59
    
@Keeper780 Does it tell you that it is an invalid command when you try to open up the software center? It is difficult to fix this because we have no idea what your IT guy did. If he opened up the terminal and typed in commands, you can see what commands he typed by opening up the .bash_history file in your home directory with a text editor (its a hidden file). –  James T Jun 13 '10 at 4:54

try running these commands in the terminal and see if they help :

sudo ifconfig eth0 up
sudo ifconfig wlan0 up

You might have to change the device names (eth0 to wlan0 which are more or less standard) to whatever they might be on you laptop. To get the network manager icon back you could right click on the bar and click on "Add to panel" and add the relevant applet (not sure which one exactly). I hope this helps.

share|improve this answer
    
Oh dear nothing happens it just skip to the next line waiting for a new commant –  Keeper780 Jun 11 '10 at 21:58
    
Thanks for trying. I'm at the stage that I might save all my files and go for a fresh re-install. I just don't want any thing to happen to M/S as it is my works O/S. –  Keeper780 Jun 11 '10 at 22:01

Ubuntu comes with two main flavors of Networking.

  • "Network Manager" is the new method intended for most desktop users.
  • /etc/init.d/networking is the old method, and is some people prefer this because this is more similar to what we used in the past.

I bet your IT guy tried to use the second method. This happens a lot, because many older Unix folks can't quite get used to Network Manager, and Network Manager doesn't do some advanced things (Conflicts with some Virtualization software, didn't handle static IPs until recently).

We need to first figure out which type are you using. Please run these commands and paste the output into your question above:

First let's look for the Unix startup scripts. I'll show you what I have.

$ sudo service --status-all 2>&1 |grep network
[ ? ]  bridge-network-interface
[ ? ]  network-interface
[ ? ]  network-interface-security
[ ? ]  network-manager
[ ? ]  networking

And let's see the status of those services. I am currently using network-manager.

$ sudo service network-manager status
network-manager start/running, process 1080

$ sudo service networking status
networking stop/waiting
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.