Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a brand new DLINK-1310B Wireless Router (box never before opened, although I bought it at the neighborhood computer junk store). I am using it at home (and in fact am using it at this instant from a wireless laptop). When operative, I can ping it at 192.168.0.1, and I can log into it from the PC attached to it by LAN and from the wireless PC at //192.168.0.1.

In the course of the day since I've installed, it seems to have locked up 3 times. Each time the symptoms are my web browser (or other IP service, e.g., POP3) stops with a "No internet connection" error.

Attempts to contact the router via 192.168.0.1 get no reaction, from either the wireless laptop or from the hardwired PC sitting next to it. It doesn't respond to pings to that address either.

Power cycling the router fixes it.

I've seen discussion in other questions about aging cheap electronics. Its too new to be aged.

Anybody else seen this behavior with a DLINK-1310? Or do I just need to exchange it for another and try again? (I hate rolling dice, I bought the DLINK because a previous Linksys died of apparant heating problems, how many do I have to cycle through before I get something that works and is long-term stable?).

Remarkably, nobody talks about how much software is in a router. Is the stuff just buggy?

EDIT: Happened again, while I was working on the wireless Vista laptop. (Seems like once an hour?) I was a little more careful this time. The wireless laptop can ping it. It can't get the login screen. I visited the LAN-connected PC (takes me a minute to walk from the laptop to the PC at the other end of the house), and attempted to visit a random web page. Surprise, that worked! And, now, after a minute walking back to the laptop, I can reconnect the wireless laptop, and get to the login page from it. Strange the time/date has been reset back to 2002. (I'll swear I set it and saved the system configuration after updating the firmware; it made me redo every other bit of reconfiguration again).

Is there something funny about wireless leases expiring? The router says the leases it is handing out are good for 180 minutes, and the delay-to-inaccessible was only about an hour. The DSL connection seems to have a 10 minute lease.

EDIT 12/2010: I gave up and threw this piece of trash away, and bought a router from a different manufacturer. Problem solved; but I won't buy another DLINK.

share|improve this question

migrated from serverfault.com Jun 11 '10 at 8:43

This question came from our site for professional system and network administrators.

1 Answer 1

up vote 1 down vote accepted

Step 1: Check to make sure you have the latest firmware
Step 2: Return the router if you're still having problems.

Truth is, consumer routers are designed to be cheap. They're made of cheap parts and often fail. This is typical of a failing consumer router. If it's doing this fresh out of the box, you got a dud. It happens.

share|improve this answer
    
Updated fimrware to 2.2 before I wrote this complaint. –  Ira Baxter Jun 10 '10 at 5:47
1  
There's lots of cheap electronics in the world. Most of it seems to work out of the box; the Japanese taught everybody how to do that. Why should routers be especially bad? –  Ira Baxter Jun 10 '10 at 5:54
    
.... oops, mistyped, updated to firmware 2.02 before I wrote this complaint. –  Ira Baxter Jun 10 '10 at 6:03
    
I'm giving you the credit for "you got a dud". –  Ira Baxter Feb 16 '11 at 6:47

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.