Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

On a laptop, we currently use LAN(RJ45) connection to access internet. But from time to time, on startup, the laptop "catch" an unsecured wifi hotspot from one of my neighbors, so we would like windows 7 to NOT choose any wifi network : how this can be done ?

share|improve this question
add comment

3 Answers

Windows shouldn't normally connect to any wireless networks. You must have connected to them at an earlier date and it has remembered this. To stop this:

  1. Open the network and sharing centre
  2. Click manage wireless networks from the menu on the right
  3. Right click -> remove the networks you don't want to connect to
share|improve this answer
add comment

You can disable wireless service.

Right-click on My Computer, services. Find Wireless Zero Configuration service and Stop it (right-click). To avoid starting it up at next boot, change it's startup type from Automatic to Manual.

Once you do need Wireless, just start service (right-click) again.

share|improve this answer
    
Wouldn't it just be easier to disable the wifi port instead? Since most laptops have a Fn key for that? –  MrStatic Jun 11 '10 at 14:43
add comment

Or, if you're already in the Network and Sharing Center, go to Change adapter settings, right-click the wireless connection, and click Disable. A UAC prompt is triggered. To re-enable, simply go back, and click Enable instead of Disable. Practically fool-proof way of disabling wireless, on any Windows OS. (Well, unless you're so old that the OS doesn't support wireless, but that's a different story).

Once again:

1) Open the Network and Sharing Center.
2) Click "Change adapter settings" in the left-hand panel of sorts.
3) Right-click "Wireless Network Connection" and click "Disable".
4) Click "Yes" to the UAC prompt, or enter an administrator password.

To re-enable:

1) Open the Network and Sharing Center.
2) Click "Change adapter settings" in the left-hand panel.
3) Right-click "Wireless Network Connection" and click "Enable".
4) Click "Yes" to the UAC prompt, or enter an administrator password.
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.