Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

In computing, tee is a command in various command-line interpreters (shells) such as Unix shells, 4DOS/4NT and Windows PowerShell, which displays or pipes the output of a command and copies it into a file or a variable. It is primarily used in conjunction with pipes and filters.

I run

echo FRAMEBUFFER=y | sudo tee /etc/initramfs-tools/conf.d/splash

twice.

I opened the conf.d folder in Nautilus, but there wasn't a splash file. I hit Ctrl+H, but still no splash file. I expected FRAMEBUFFER=y to be inside a splash file inside the conf.d directory, but instead of that a resume file is in the conf.d directory with a completely different line which is:

RESUME=UUID=d9da4acc-b432-4cc3-927a-5815aa2e1071

Is this going to be a problem?

share|improve this question
2  
sounds like your command didn't execute. were you prompted for a password? run this command in a terminal: sudo ls -l /etc/initramfs-tools/conf.d/ –  quack quixote Jun 11 '10 at 19:59
    
Also, why would you use tee for that, rather than just doing something like echo text > /etc/file ? –  Dentrasi Jun 11 '10 at 21:05
3  
when you do 'sudo command > file' the redirection takes place within your current shell, with your current permissions. By doing 'sudo tee' the file is opened with the permissions under the sudo. In otherwords, the tee works, the echo wouldn't. –  gorilla Jun 12 '10 at 0:59
    
quack quixote, you were right! I was using ALT+F2 with run in Terminal marked and that way somehow sudo tee doesn't run. Now, I used Accessories -> Terminal instead and it run. Also, your sudo ls was listing only resume, but now it's listing splash too. –  Delirium tremens Jun 15 '10 at 17:24
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.