Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My system is an HP netbook running Ubuntu 10 netbook edition from a USB drive. I created an admin account and user account, and left in place the 'ubuntu' account.

My netbook came with Windows 7 factory loaded and I did some work in Windows before setting up Linux. I copied my work into the HP Tools FAT32 partition that also came Factory Loaded, and was only 20% full.

Only the 'ubuntu' account shows the HP Tools partition. So I would like to either view the partition from the 'admin' or 'user' accounts, or copy files from the partition-to a folder accessible from admin or user.

I have already tried right clicking the folder, selecting share, and installing the share package, but I got a string of errors and would prefer a short term, one time solution that does not involve installing the share package. All I need is a few plain text Windows files i was working on.

share|improve this question
    
Perhaps you could list what errors you are getting? –  MDMarra Jun 12 '10 at 12:27
    
These are the errors I got: E: Type 'aufs' is not known on line 1 in source list /etc/apt/sources.list E: The list of sources could not be read. Go to the repository dialog to correct the problem. E: _cache->open() failed, please report. –  CDeanMartin Jun 12 '10 at 12:48

1 Answer 1

As a one-time solution to move your data from the FAT32 partition on your laptop to say your Ubuntu login home area, you can do the following steps.

  1. login as 'ubuntu' which you say has access to the FAT32 partition.
    You can do other things with 'sudo' and 'mount' if you are used to the linux prompt.
  2. copy the desired data to your USB linux partitions
    You can copy it to the 'ubuntu' or the 'admin' home area too.
  3. log-off and re-login as 'user',
    open a terminal (applications, terminal) and change to the '/home/admin/' area.
  4. you should find your files there, copy them to your home area or where-ever you desire

I have not quite understood your problem with mounting the FAT32 partition.
Maybe, it is related to the permissions setup for the user login you created. Something missing in the User Privileges controls for your user login (check how to reach to that control on this link). Its at System > Administration > Users and Groups, then properties for the user and the User Privileges tab.

share|improve this answer
    
This solved my problem. –  CDeanMartin Jun 14 '10 at 7:45
    
Please update which part solved your problem -- the one-time-solution or the permissions related part? –  nik Jun 14 '10 at 15:44
    
If the problem is solved, it would be polite of you to mark this answer as correct. –  CarlF Jun 12 '11 at 18:37

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.