Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

So, I just discovered that you can hide the file names of pictures and videos when you are in a thumbnail view in explorer (via View - Hide file names)... but often I have other files mixed in. This causes the thumbnails to be all spaced out. How can I hide all file names (maybe folders too)?

share|improve this question

Windows 7 displays the file name when it doesn't know how to handle it or when there is no program connected to it. This is not possible with folders.

look for something like default applications in the control panel (I don't have a Win7 install with me atm).

Hope this helps ; )

EDIT: I think I have the solution: Try going to "Control Panel->Appearance and Personalization->Folder Options->View" and check "Hide extensions for known file types". I though this was default, but maybe it's not.

share|improve this answer
    
Although I couldn't find .zip and .exe files in Default Programs - Set Associations, .mp3 and .flv files are... and their filenames remain as well. The flv files even have proper thumbnails. – Saebin Jun 12 '10 at 19:34
    
Answer updated. If this was what you were looking for please accept the answer and +1 – Kristoffer Hagen Jun 12 '10 at 19:47
    
All that did was hide the extension of the files (which is default, it turned it off), the rest of the name is still there. – Saebin Jun 12 '10 at 20:45

Right click, select customize this folder, select pictures, click apply and OK. Now click view and Hide Filenames. The hide filenames only shows up when folder is customized for pictures.

share|improve this answer

I realize this is an old post, but I wanted an answer to this same question and was disappointed there wasn't one here. Here's what I found:

You have to change the "Kind" of the file extension in the registry (Win+R, "regedit.exe"). To do this go to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\KindMap and find the extension you want to hide the filename of (in my case this was .pdf) and change the value to picture.

If you haven't already, you also need to change what the folder is optimized for by right-clicking the folder (or empty space when you're exploring the folder's contents) select properties then customize. In the dropdown select "Pictures" (may say something like "videos/images" in other versions of Windows) and press OK. Then, inside the folder right-click>View>Hide File Names.

Sources: http://www.howtogeek.com/howto/16694/customize-the-five-windows-folder-templates/ https://msdn.microsoft.com/en-us/library/windows/desktop/cc144136(v=vs.85).aspx

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.