Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm running Google Chrome (6.0.427.0 dev) on Windows 7 Home Premium 64-bit (AMD Phenom 3.00 GHz, 8 GB RAM). The computer lockups hard after running Chrome for about five minutes. The lockup happens whether Chrome is actually being used to browse web sites or it is just idling. No programs can be started or interacted with when this happens. The computer must be power-cycled to recover.

The lockup happens regardless of which web sites are being browsed.

The system event logs do not show any events around the time when the lockup transpired.

All other applications run just fine on this system. In fact, Chrome ran without issue for several months on this system (the system was brand new 03-2010).

I also run the same version of Chrome on other computers (Windows XP SP3) without issue.

I've come to really like Chrome and use it as my default browser whenever possible.

What could be causing Chrome to cause the system to lockup as it does? Does Chrome have any logs that aren't part of the Windows event log? Does Chrome have a debug command line switch that might reveal more about what happens?

share|improve this question
add comment

3 Answers

up vote 1 down vote accepted

Chrome 6.0.427.0 dev is the latest development release. I'd expect to find problems with it. You can report bugs here. Chrome 5.0.375.70 is the latest stable release.

The Google Chrome release blog has more information.

share|improve this answer
    
I didn't notice when it actually happened, but one of the automatic Chrome updates resolved the issue. Chrome has been free from lockups for at least a couple of weeks now. –  Mike Chess Jul 1 '10 at 20:19
add comment

I had a similar problem, but in my case, Chrome was freezing my Windows 7 64-bit PC for 3-4 seconds every 20 seconds or so. This answer from the link 1 helped.

AUTO DISCOVERYING PROXY: The "auto detect proxy" function of Win 7 may be causing lag for some users. To disable it, go to Wrench->Options->Under the Hood->Change Proxy Settings. Click "LAN settings" and uncheck "automatically detect settings". Additionally click "Settings" (if it's not grayed out) and uncheck "Automatically detect settings" here too. Hit OK until you get back to the browser. Test to see if the problem has gone away."

share|improve this answer
add comment

Have you tried re-installing Chrome? If that doesn't work then you might consider switching to a different browser, like Firefox for example.

share|improve this answer
    
No, I haven't tried reinstalling Chrome. That's a poor option for dealing with software that is not working correctly. I also have many other browsers (Internet Explorer, Firefox, and Safari among others) installed. I develop software, so having a variety of browsers available is a prerequisite. The reinstall dance, however, may be the only viable option. –  Mike Chess Jun 12 '10 at 19:58
    
If I recall correctly, reinstalling Firefox is relatively painless. The only problem you might have is having to manually re-add the profile, which takes a total of 30 seconds. –  Hello71 Jun 12 '10 at 21:31
    
@Mike you can't really expect them to offer support on the Developer version, wouldn't you agree? It's not even Beta! –  Ivo Flipse Jun 18 '10 at 8:48
    
@Ivo - That's part of the reason that I asked here. I've been using Chrome since it hit open beta and have had no problems with it (except this one). –  Mike Chess Jun 19 '10 at 22:13
    
I think I just read some new about the latest Dev version being buggy and that they froze further updates before they fixed it. Guess you might have been a victim –  Ivo Flipse Jun 20 '10 at 14:33
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.