Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

In my WinXP box, I have these "programs" installed:

  • Microsoft .NET Framework 1.1
  • Microsoft .NET Framework 2.0 SP2
  • Microsoft .NET Framework 3.0 SP2
  • Microsoft .NET Framework 3.5 SP1

Do I need all four versions? Can software compiled on .NET 1.1 run on a 3.5 runtime?

share|improve this question
add comment

4 Answers

up vote 1 down vote accepted

Darth Android is a little wrong. The .NET Framework is a 'stack' of all versions. The libraries of 1.1 form the major core of 2.0, 2.0 forms the core of 3.0 and so on...every new version is based upon (or better enhances) it's predecessors.

So, yes, you need all four.

share|improve this answer
4  
Framework 1.1 does not form a core of 2.0. Framework 1.1 is independent from the others. 2.0/3.0/3.5 belong to the same set and each requires its predecessor. But while 3.5 and 3.0 require 2.0, neither 3.5 nor 3.0 or 2.0 require 1.1. –  Andrew J. Brehm Nov 10 '11 at 15:12
add comment

Yes, you need all four, unless you've uninstalled all programs using them (which is hard to work out). Leave them.

Do make sure you've patched them up to date as well!

share|improve this answer
add comment

It depends on the .Net Application. First, removing .Net Framework can be very painful. Once installed it's best to leave it on the system. So be sure to know the requirements of the application before you install .Net Framework.

My experiences so far:

  1. Seen an app that requires 2.0 for installation, but accepts if only 3.5 was installed. I've actually seen several commercial apps like this. And after the install they do run.

  2. Seen an app that required 1.1 and if you installed any other version, would break the app. This was a custom payment app built for a government body. I was not impressed when I had to call the vendor for support.

share|improve this answer
    
2.0 and 3.5 are based on the same Common Language Runtime, so it's no wonder the applications are basically compatible. 4 is the first release using a different runtime again. Regarding the custom application, has it been maintained since 2.0 was released? Seems like a typical "unmaintained software" issue. –  Daniel Beck Sep 16 '11 at 20:39
add comment

Generally speaking, no. Each major version of the framework is different enough that programs aren't compatible to my knowledge.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.