Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I haven't been able to figure out if there's a way for me to get the latest version of MonoDevelop in Hardy. Would someone be able to help?

share|improve this question
1  
have you tried? what have you tried so far? where are you stuck? –  quack quixote Jun 12 '10 at 21:17
    
ya, i did. a while back, and i gave up, even though i'm no newbie. i asked this because i thought there was going to be a straight yes-no answer, so as to devote the time to try again. –  Dervin Thunk Jun 12 '10 at 21:34

1 Answer 1

up vote 0 down vote accepted

Yes you can. But you need updated Mono also. Then, you can compile it (if it doesn't depend on something else besides mono.).

(Usual way:
1) sudo apt-get build-dep monodevelop build-essential
2) cd /where/the/monodevelop/source/is/
3) ./configure --prefix=/usr #here you configure it up. Type ./configure --help to see your options. It'll also check for dependencies, it'll tell you if you still miss something.
4) make #basically you make the binaries in this step
5) sudo make install #this will actually install it

(NOTE! I wrote the "usual way". There is no guarantee that this will work. Make sure you READ the README/INSTALL file in the source folder of Monodevelop. Also, keep the source folder (what you used for install). You will be able to delete it later using this folder and issuing the command: sudo make uninstall.)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.