Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

all. I'm unable to make my router perform a hardware reset, and I cannot understand why. The router is a WRT54GC (the little one).

All was working well, except that my iPhone could not connect to the wireless. I found that the router was only allowing AES encryption on WPA2 Personal mode, so I upgraded the firmware. I updated the firmware to Ver.1.06.1, and everything went screwy.

  • The router is no longer showing up in the WiFi list (as Linksys, or its previous network name).
  • Wiring into the router gives me an IP address from my ISP (24.121.121.XXX).
  • Attempting to do a hardware reset, but the power light never starts flashing and the router does not seem to reboot.
    • My machine wired in is still online with no interruption in WoW.
  • Pulling the power cord to force a reset returns it to the same state.

I even went so far as to pull up my previous IP address (from DynDNS) and try to connect to that, but it wont even ping.

What I'm trying to find out is: Did the new firmware fry the thing, or is there some way to fix this?

Thanks in advance for any help.

share|improve this question
Just FYI - Using TKIP instead of AES defeats the purpose of WPA2 and will drop the wireless access point into WPA/WPA2 mixed mode. iPhones have no problem using WPA2+AES. – MDMarra Jun 13 '10 at 22:29
I just know what I read: – Jack M. Jun 14 '10 at 14:26
I had an iPhone and currently have an iPod touch, I've configured them both to work with my home network (WPA2 PSK) and work network (WPA2 Enterprise) and both work. My comment about TKIP vs. AES was that WPA2 was created to close a vulnerability in the TKIP algorithm that WPA used. This was solved by switching to AES as the standard encryption for WPA2. Using TKIP with WPA2 is the same as using WPA for all intents and purposes. – MDMarra Jun 14 '10 at 15:47

If the router is 'bricked' you may have to resort to more drastic measures :(

First thing to try is the 30/30/30 reset:

  1. Disconnect all network cables, not the power cable.
  2. Push reset button for 30 secs.
  3. Without releasing reset button, disconnect power lead.
  4. Hold the reset button for another 30 secs.
  5. Replug the power lead.
  6. Continue holding the reset button for another 30 secs.
  7. Release the reset button and leave the router for about 10 secs.
  8. Disconnect power cord for another 10 secs and then reconnect.

With any luck that may have reset the router. If not (you don't mention which model linksys) you could take a look here:

The Wrt54g Revival Guide

There are similar routines for other models.

share|improve this answer
oops. It's a WRT54GC, I'll add that to the post. I tried the 30/30/30 reset. No avail. =-[ – Jack M. Jun 13 '10 at 22:19
Unfortunately, it does sound like the firmware update went wrong somewhere. In reality, I think you have two options, try to short pins 15 and 16 on the flash chip (as described in the 'Revival guide) or accept that it's dead and go for a new one :( – Pulse Jun 14 '10 at 1:32
up vote 1 down vote accepted

It appears that this router is simply dead. Either the firmware I installed was corrupt, or the thing just gave up on life.

The solution is: Go buy a new router if the above doesn't work.

share|improve this answer

I had a similar problem a year ago with a Linksys Router. Mine ended up just being dead. I had used it for about 8-9 months when this happened and I tried a ton of different things to get it to hardware reset with no luck. I am not saying yours is dead, just that there is a small chance that it is!

share|improve this answer

I have a Linksys WRT 160N and the 30-30-30 rule doesn't work. What works for me is I put the box in the freezer for 10-15min. Then it powers up normally.

share|improve this answer
What made you do this as a solution? – Matthew Williams Jul 16 '14 at 13:21

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .