Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

On a new installation of Ubuntu 8.04.2 LTS, logging in as a standard user does not maintain the keybindings (whether through sudo su - or direct from ssh). As the root user everything is fine and /root/.inputrc does not exist (only /etc/inputrc) which has its default settings.

In addition setting a ~/.bashrc and ~/.profile to the same as the root user (and chown'ing to user:user) has no effect.

Am I missing something here?

share|improve this question
    
is /etc/inputrc the only place you're trying to change keybindings? – quack quixote Jun 13 '10 at 6:58

Turns out the terminal was set to /bin/sh instead of /bin/bash by default. Switching to the correct terminal sorted things out!

FYI the installation is on a Rackspace Cloud Server, not sure if this applies to a default Ubuntu 8.04 installation.

share|improve this answer
1  
That's "shell" rather than "terminal". – Dennis Williamson Jun 13 '10 at 8:14

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .