Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have an Acer Aspire 5710 which came pre-loaded with Windows Vista. O/S has been changed to Win SXP SP2 and was working fine till today.

The laptop starts up and then hangs (does not reach till the Windows screen). Have tried the following

  • Repair with XP CD.
  • Re-install with XP CD (In both cases the error "No hard disk" is displayed.)

  • Tried F5/F8 to boot with other options.

Guess the hard-disk is not being recognised. The 160 Gb SATA disk is shown as IDE0 in the Phoenix Bios. There is no floppy drive.

Any suggestions.

Thanks, Sri.

share|improve this question

The simplest - and saddest - answer seems to be that the hard drive has failed and will have to be replaced. A disk recovery service might be able to retrieve some data from the drive if you don't have a backup.

There's a small (likely very small) chance that the SATA interface hardware on the PC has failed and the drive will work in another PC. I wouldn't hold out too much hope though.

share|improve this answer
Thanks Wayne. Are there any standard connectors available for such HD. I tried using some of the USB/external drives, but they dont match. Thanks, Sri – Sri Jun 14 '10 at 4:34
You can buy external adaptors - google external SATA adaptor for some sources. However, if the drive has failed this won't help. Since that's the most likely cause I'd start by visiting a repair shop. They likely have an adaptor they can test your drive with. And they can give you better advice by having a look at the PC and doing some tests. – Wayne Johnston Jun 16 '10 at 1:07
hi wayne, tried an external reader and the hard disk was detected and able to read the contents. Presuming that hardware works fine, tried to repair/re-install. On the screen where options Repair, Quit and Enter are displayed, keypad hangs, but function keys work, i.e. F3 works, but enter and repair (R) dont. Any ideas – Sri Jul 11 '10 at 9:35
Well, I'm surprised. It's almost always the hard drive that fails, not the PC. Still that's good news for the information on the drive. You've now gone beyond my simple skills. It seems there is some sort of fault on the mother board or on something connected to it. I think you better have someone experienced look at it. – Wayne Johnston Jul 13 '10 at 3:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .