Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

after a lovely blue screen of death my Windows Vista 64-bit machine decided to reconfigure one of my drives to no longer be part of my raid volume. So now my raid fails as it only has one member disk. This happened to me about 6 months ago and I just changed the disk in question back to a raid disk and all was well. However I cant seem to find that option in my bios or raid config anymore. :(

Any help would be appreciated.

share|improve this question

migrated from serverfault.com Jun 13 '10 at 18:00

This question came from our site for system and network administrators.

    
I think last time the "configure SATA as" option changed to IDE, i just changed it back to Raid and it worked. However this is still on Raid for me now. Just one of my drives is a "non-Raid disk" and i dont know how to change it back to a "member disk" –  Alan Jun 12 '10 at 17:16
    
Yes I defiantly have a RAID card, I also understand that RAID0 has no redundancy but still think its a little wierd that a crash with no data loss or hardware failure can render my data unrecoverable. Why cant I just set the disk in question back to be a member of the raid array. –  Alan Jun 12 '10 at 18:26
    
Thanks for your help! So I actually have 2 raid controllers that are par of my motherboard. I dont know if that makes a difference. Its an asus p5k ws –  Alan Jun 12 '10 at 19:04

1 Answer 1

Do you really have a RAID card or just JBOD ?

If you have JBOD, stop using this as it is not a real RAID and will cause more problems than it will prevent them. (as per my experience)

If you really have a RAID 0 and it failed, you can't go back since a RAID 0 doen't have any redundancy.

Since your data is saved across both disks, if one fails, you lose everything. Sorry.

See the difference http:// en.wikipedia.org/wiki/RAID_1#RAID_1 vs http:// en.wikipedia.org/wiki/RAID_0#RAID_0

Read more articles about RAID on http://www.developerit.com

share|improve this answer
    
I think you can't because adding a new member into a RAID 0 array will erase all data on the new disk.... since you only have 2, you will loose everything so the raid configuration software won't let you do it since your RAID is not 100% healthy since you lost a disk... What is your RAID card ? Maybe your supplier can hep you because each RAID card as it's own way of working. –  Developer IT Jun 12 '10 at 18:44
    
Hi me again... I looked at hexus.net/content/… for your motherboard and I see: RAID 0, 1, 10 and 5 through Intel ICH9R --> This chip looks like a JBOD and not a real RAID... did you tried Intel fireware update ? –  Developer IT Jun 12 '10 at 21:40
    
Hi, i havent tried a firmware update yet. I actualy decided to delete the raid and recreate it as i have a back up image thats only 2 days old. However I am getting the same problem with i go to recreate teh raid, its only adding one of the drives. Do you have any idea why that may be? The other one is still being labled as a non-raid disk –  Alan Jun 12 '10 at 21:53
    
If data loss is not a problem then I would really format the two drives then create a RAID 1 (miroir) not 0 (stripped). If performance is really a issue then go with RAID 0 but do backups daily. The disk still marked as non-raid may need a MBR format (I guess your on NTFS since your with Vista) –  Developer IT Jun 12 '10 at 22:48
    
I would really recommand doign a fireware update BEFORE mounting the new RAID. This may prevent new BSOD. –  Developer IT Jun 12 '10 at 22:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.