Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am getting this error while trying to install RMagick:

$ sudo gem install rmagick

Building native extensions.  This could take a while...
ERROR:  Error installing rmagick:
    ERROR: Failed to build gem native extension.

/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/bin/ruby extconf.rb
checking for Ruby version >= 1.8.5... yes
checking for gcc... yes
checking for Magick-config... no
Can't install RMagick 2.13.1. Can't find Magick-config in /usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin:/usr/X11/bin:/opt/local/bin:/usr/local/git/bin:~/bin:/usr/local/bin:/usr/local/mysql/bin:/usr/local/pear/bin

*** extconf.rb failed ***
Could not create Makefile due to some reason, probably lack of
necessary libraries and/or headers.  Check the mkmf.log file for more
details.  You may need configuration options.

Provided configuration options:
    --with-opt-dir
    --without-opt-dir
    --with-opt-include
    --without-opt-include=${opt-dir}/include
    --with-opt-lib
    --without-opt-lib=${opt-dir}/lib
    --with-make-prog
    --without-make-prog
    --srcdir=.
    --curdir
    --ruby=/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/bin/ruby


Gem files will remain installed in /Library/Ruby/Gems/1.8/gems/rmagick-2.13.1 for inspection.
Results logged to /Library/Ruby/Gems/1.8/gems/rmagick-2.13.1/ext/RMagick/gem_make.out

How can I install the RMagick RubyGem on Snow Leopard?

share|improve this question
add comment

5 Answers

up vote 4 down vote accepted

You might also consider taking Homebrew for a spin. It's been growing over the last year and is widely used as an alternative to MacPorts.

Homebrew is a reaction to the complexity of MacPorts. It’s extremely simple. Homebrew appears to be targeted more at individual packages. If you want to pull in the entire world of open source software and want every package, then you’re better off with MacPorts or Fink. But if you’re looking for the occasional tool or utility, Homebrew is for you.

share|improve this answer
    
Homebrew is awesome! Although, if I remember correctly, I couldn't get the Homebrew Rmagick to work when I tried it, so I had to fall back to using some script I found on the internet. –  Andrew Oct 24 '11 at 20:14
    
I'm not sure when you tried it last, but I'm been using Homebrew and Imagemagick with the Rmagick gem on my machine and it works great. –  ere Oct 27 '11 at 8:05
    
I think they must have fixed all the bugs because I tried it again and got it to work. –  Andrew Jan 22 '12 at 23:07
add comment

I found a way to do it without having to use MacPorts. Thanks to a shell script to Install ImageMagick on Snow Leopard, I was easily able to run the script and have ImageMagick and all of its dependencies installed automatically.

First you need to download the script. If you have git installed...

cd ~/src
git clone git://github.com/masterkain/ImageMagick-sl.git
cd ImageMagick-sl
sh install_im.sh

At one point, it runs a command using sudo, so it will ask for your password. After the script has finished, ImageMagick will be installed. Now, to install the RMagick gem...

sudo gem install rmagick

That's it!

share|improve this answer
    
It would seem this no longer works? ... 'try_do': The complier failed to generate an executable file. (RuntimeError) You have to install development tools first. –  ardavis Aug 23 '11 at 1:45
    
Have you installed the development tools yet? I think you need to install XCode first. I think the "development tools" are included when you install XCode. –  Andrew Aug 23 '11 at 4:23
    
I do have XCode, I think the issue was resolved. I think I had multiple installations of ImageMagick conflicting. –  ardavis Aug 23 '11 at 4:27
    
None of the answers work for me. I discovered that I do have Magick-config in /opt/local/bin (probably from the port install ImageMagick but I'm not sure), but gem install does not have /opt/local/bin in its path so it's not finding it –  Bogatyr Apr 11 '13 at 19:51
    
I solved this issue now: rvm installation blew away my .bash_profile contents, which included the macports PATH setup. After restoring /opt/local/bin to PATH, the macports ImageMagick was found by gem install rmagick, which then succeeded. –  Bogatyr Apr 12 '13 at 4:40
add comment

OS X does not come with ImageMagick installed by default. The ImageMagick home page provides a binary installation, although they recommend using MacPorts instead. I would recommend using MacPorts as well, since it is a great package management system that keeps you up to date with your Unix-like software versus Apple's provided versions.

Having said that, Rubyforge has some instructions on installing RMagick on OS X using MacPorts. It's slightly dated, and you might need to choose different variants for the ImageMagick installation, but it should work to get what you want.

share|improve this answer
1  
the RubyForge worked fine for me –  PowerKiKi Jan 6 '11 at 11:06
    
The MacPorts ImageMagick worked fine for me. The only trouble was that rvm installation clobbered my .bash_profile contents, which ended up removing /opt/local/bin from my PATH. After restoring /opt.local/bin to the PATH, the MacPorts ImageMagick worked fine for installing the rmagick gem. –  Bogatyr Apr 12 '13 at 4:42
add comment

And the ImageMagick FTP call in the script needs to be updated to ftp://ftp.imagemagick.org/pub/ImageMagick/ImageMagick.tar.gz

There are two occurrences of the libpng path and two of the ImageMagick path which need to be updated.

Aaron

share|improve this answer
add comment

You can also install ImageMagick package using mac ports

sudo port install rb-rmagick

and than install gem

sudo gem install rmagick

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.