Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have the following /etc/fstab:

# /etc/fstab: static file system information.
#
# <file system> <mount point>     <type>      <options>                  <dump>  <pass>
proc            /proc             proc        defaults                   0       0
/dev/md1        /                 ext3        defaults,errors=remount-ro 0       1
/dev/md0        /boot             ext3        defaults                   0       2
/dev/md5        /home             ext3        defaults                   0       2
/dev/md3        /opt              ext3        defaults                   0       2
/dev/md6        /tmp              ext3        defaults                   0       2
/dev/md2        /usr              ext3        defaults                   0       2
/dev/md4        /var              ext3        defaults                   0       2
/dev/md7        none              swap        sw                         0       0
/dev/sdc        /home/httpd       ext3        defaults                   0       2
/dev/hda        /media/cdrom0     udf,iso9660 user,noauto                0       0
/dev/sdc1       /mnt/usb/backup-1 auto        defaults                   0       0

I am unable to get /dev/sdc/, an internal SATA hard disk, to mount at /home/httpd/ on reboot. The /home/httpd/ directory exists.

Mounting via mount -t ext3 /dev/sdc /home/httpd works just fine.

Mounting via mount -a generates the following error message:

mount: you must specify the filesystem type

This is, incidentally, the same message that I see while booting. The error message goes away if I comment out the line in fstab starting with /dev/sdc.

share|improve this question
    
what exactly is /dev/sdc? internal hard drive? USB drive? removable card reader device? –  quack quixote Jun 14 '10 at 15:31
add comment

1 Answer

up vote 4 down vote accepted

There is an error in your fstab: you cannot simultaneously have a valid filesystem both on /dev/sdc and /dev/sdc1. One of these commands (or maybe two) will definitely fail, and as mount /dev/sdc works fine, the failing one is second. Also it probably prevents second mount from executing; while I don't know exactly, it should work. And if you want to check a line in fstab for correctness, don't specify the mountpoint: this will force mount to lookup it (and other options) in fstab effectively verifying your setup.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.