Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

In Ubuntu, when we right-click a icon and use "open with", there is an option to remember that application for that file's type.

For some reason, my system is no more memorizing the application (I think it was aftare some update).

And, even when I have already used the "open with" command, the application is not showing in the "open with" list, so I have, everytime, to go to "open with"->"Other Application".

The system used to ask me what to do with the file type (Display, Run..), but now it is doing nothing to my file type "ppf". I want it to open with GEdit. Is there any command line to associate my extension with GEdit?

share|improve this question

Mine never did remember settings when set via the Nautilus "open with" dialog. (I was trying to make VLC my default player for various video filetypes -- AVI, etc -- and it never stuck.)

I eventually got the setting to stick using Ubuntu Tweak's File Type Manager.

sudo add-apt-repository ppa:tualatrix/ppa

sudo aptitude update

sudo aptitude install ubuntu-tweak

Afterwards, Ubuntu Tweak should be available in your Gnome menu: Applications > System Tools > Ubuntu Tweak. Select File Type Manager in the left-hand column, select a filetype category, select a filetype, click the Edit button. There you can select from your system's known choices, or use Add to add a new choice or custom command.

See Adding MIME Types in the Ubuntu Help pages. To make a new MIME type, you can simply add the type to /etc/mime.types and the icon to /usr/share/icons/gnome/*/mimetypes (put SVGs in ...gnome/scalable/mimetypes, and PNGs in the size directories).

There seems to be a way to make this slightly more automatic via XDG. You can use the xdg-mime command to query what your system knows about MIME types and add new ones. See man xdg-mime; install the xdg-utils package if you don't have this command.

If your PPF files are just plain text, you might be able to get away with adding "ppf" to the existing text/plain definition in /etc/mime.types:

text/plain                  asc txt text pot brf ppf
share|improve this answer
An error has occurred: Error reading HTTP Error 404: Not Found – Tom Brito Jun 14 '10 at 17:02
The above error occurred on the first line – Tom Brito Jun 14 '10 at 17:09
@Tom: watch out for typos; that should be ppa on the end not paa: .. in case it's not obvious, your system will need an internet connection to run those commands. i've just double-checked; these commands are working on my system. – quack quixote Jun 14 '10 at 17:12
Thanks! But, now installed, there are just options to edit known file types, even when unmarking "Only show filetypes with associated applications". I need to register a new file type, "ppf", to open with gedit, is there a way? – Tom Brito Jun 14 '10 at 17:58
@tom: sorry, i'm a little lost there myself. ... hang on, updating the answer here. – quack quixote Jun 14 '10 at 18:35

Right-click the document icon in nautilus, then choose Properties | Open With. This will allow you to choose the default application to launch it with, as well as modify the applications that show by default in the context menu of documents of that type.

share|improve this answer
it is already marked GEdit, but when I click (or press enter) it just don't react... nothing happens. And I think this started after one of the Ubuntu updates, but I don't know what was updated... any other idea? – Tom Brito Jun 15 '10 at 13:03
found, after unmark "Allow executing file as a program" it worked.. I don't know why this box was marked anyway.. – Tom Brito Jun 15 '10 at 13:07

I was having this trouble until I noticed that my boot partition was full and cleared some space. It was interesting - I released a few tens of megabytes and that freed up the system enough to work and then it somehow released more than a gigabyte on that partition that it was holding for some reason or another. Whew.

share|improve this answer
up vote 0 down vote accepted

Found, after unmark "Allow executing file as a program" it worked.. I don't know why this box was marked anyway..

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.