Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

How can I hide my network connections (the PC with the red X icon on the task bar) when I'm not using a that connection.

Typically, I switch back and forth between wireless and wide connections depending on my location, so I don't want to just simply disable the network device.

share|improve this question
Which version of windows are you using? – BloodPhilia Jun 14 '10 at 16:01
XP, but I imagine the answer should be relatively the same for anything from 2K3, and beyond. – BIBD Jun 14 '10 at 17:49

Go to 'Network Connections' or 'Network and Sharing Center', right click on the connection you want to hide and click on Properties. Then uncheck 'Notify me when this connection..'.

share|improve this answer

Does unchecking the box in the properties that says "Notify me when this connection has little or no connectivity" do what you want?

share|improve this answer
Nope. The icon remains in either mode. – BIBD Jun 14 '10 at 20:55

Since Tofystedeth's suggestion didn't work, can you convince XP to still "diplay" the icon, but just hide it out of sight instead?

  1. Right-click the Start button and choose properties
  2. Switch to the Taskbar tab at the top.
  3. Tick "Hide Inactive Icons" if it isn't already ticked.
  4. Click the "Customise..." button
  5. Set the relevant icon to "Always Hide".
share|improve this answer
Oddly enough, it doesn't hide that icon (a couple others, but not the network one :-/ ). – BIBD Jun 15 '10 at 14:46
To return to Tofystedeth's suggestion again - have you got the corresponding "Show icon in notification area when connected" ticked? If you've got it ticked - what happens if you untick it? (I'm thinking it could be that Windows treats that as some type of override on the other suggested options?) – DMA57361 Jun 15 '10 at 15:12

I'm facing the same problem. Once my wifi lost connection, the red X icon would display on the taskbar. Fun fact is that someone had give an correct answer but you need to clear items history of Notification Area first. So the whole steps are blow:

  1. Start –> Run –> regedit (or Win + R, -> regedit);
  2. Find the following key: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\TrayNotify
  3. Delete IconStreams and PastIconsStream from the right hand pane. This will clear off the notification area history which Windows is maintaining (like caches). You need to restart Windows explorer or restart the computer for the changes to take effect
  4. Right click the taskbar and choose properties;
  5. Tick "Hide Inactive Icons" if it isn't already ticked;
  6. Click the "Customise(c)..." button;
  7. Set the network connections icon to "Always Hide".
share|improve this answer

Goto 'Network Connections' right click on the connections not in use and click 'disable'.

That will turn off the hardware for the connection and make the taskbar icon disappear.

I typically turn off all of the connections that are not in use because it also has the added benefit of saving power.

Note: If you want to add 'Network Connections' to the 'Start Menu', right click on the 'Start' button, goto 'Properties', and find the option in the menu to add a link to the 'Network Connections' folder in the 'Start Menu'.

SideNote: You can also turn off your cd drive in Control Panel->System->Hardware find it in the menu, right click and disable. It's especially nice if you have a cd drive that is unnecessarily loud/obnoxious.

share|improve this answer
As I said; because I switch back and forth between wire and wireless, depending on where I am working, don't want to disable and enable network connections all the time. – BIBD Jun 15 '10 at 14:49
Oops, I read your question completely wrong... You could try to check the network properties. Instead of right-clicking and disabling right click and hit properties. Somewhere under the settings menu there should be a checkbox along the lines of 'hide inactive icon'. I'd check myself but I'm on Linux right now. – Evan Plaice Jun 15 '10 at 20:59

Check out my screenshot in my answer to a different question here. Click the show the tray icon in your case.

Hope this helps.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.