Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Is there any way to create a 2-dimensional virtual desktop space in Ubuntu? The only control I'm seeing is the number of virtual desktops, but they seem to only go in a line. I'm used to having a 2-dimensional space (so I can go up/down/left/right instead of just left/right), and I'd really like to have that in ubuntu as well.

share|improve this question

1 Answer 1

up vote 1 down vote accepted

If you're using the default Gnome configuration in Ubuntu, you should have a "workspace switcher" panel applet in the bottom panel, on the right. Right click, and select Preferences. That will pull up a small dialog with Columns and Rows.

  • Columns is the number of workspaces across.
  • Rows is the number of workspaces down.

The total number of workspaces is Columns times Rows. For example,

There are several other places you can set this, including in the CompizConfig Settings Manager (under General Options, on the Desktop Size tab).

Tips:
Go into System > Preferences > Keyboard Shortcuts and set "Switch to workspace above the current workspace" to Win+Up. Do the same for the other directions/arrow keys.

If you add multiple rows, you may want to increase the size of the bottom panel (right-click > Preferences) so the Workspace Switcher applet is decently usable. (I found 36 pixels a reasonable size for 2 rows.)

Caveats:
If you've enabled the Compiz Desktop Cube instead of the Desktop Wall, only one row of workspaces can be accessed on the cube at a time. To switch rows, use the Expo (Win+E).

share|improve this answer
    
I tried using the Win key for setting other stuff, but it doesn't seem to work. It doesn't seem to want to treat the win (super) key as a toggle. –  Herms Jun 14 '10 at 16:50
    
@herms: i'm using it as a modifier key, like Ctrl or Shift or Alt. so hold-win-while-pressing-E (to access Expo, for example). my system calls that key "Mod4" in some places, "Super" in others. –  quack quixote Jun 14 '10 at 16:59
    
Hm. When I tried to set Win-L for lock it triggered as soon as I hit the Win key, and then any time I hit the win key after that it locked the window. Though I just tried Win-E and it did do expo. Hmm. –  Herms Jun 14 '10 at 17:14
    
Yea, just tried it. In the Keyboard Shortcuts section when I select something to remap, as soon as I hit the win key it just puts "Super L" (for left win key) there, instead of letting me use it as a modifier. –  Herms Jun 14 '10 at 17:15
    
@herms: hmm. dunno. have you enabled the "sticky keys" accessibility tool or something? tried with the right win key instead? maybe try Shift+Win+ArrowKey or Ctrl+Alt+ArrowKey or Shift+Ctrl+Alt+ArrowKey ... btw, were you able to add another row with the workspace switcher preferences? –  quack quixote Jun 14 '10 at 17:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.