Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am using Windows XP and this morning it didn't boot, it showed an error on "Windows/system32/config/SYSTEM" so I connected the hd to another pc, rename that file and then copy the one in Windows/Repair. And now it shows the error cannot find or corrupted "ntfs.sys".

I tried copying ntfs.sys from the windows installation cd but still get the same error, also tried "EXPAND :\i836\ntoskrnl.exe ( and ntkrnlpa.exe ) :\Windows\System32" but the error persist.

What other fixes can I try?

share|improve this question
You DO NOT want to copy that file. If you did a quick Google, you would have seen that that is actually part of the system registry. Changing the file will result in an inconsistent registry, which is, of course, BAD. – Hello71 Jun 15 '10 at 22:21
And what error is this? – Hello71 Jul 6 '10 at 0:49

First, by using the file in Repair, you have in essence reverted your hardware config back to your install state. If you haven't disabled system restore, I would recommend restoring the SYSTEM file from a recent restore point. (Go back a few days... but not too far back).

As for the NTFS.SYS file, you don't want the file from the install disk, most likely, as it is old (especially if your install disk is old - you are likely running SP3 (or at least 2) and your disk is probably RTM or MAYBE SP1). Try getting the file from another system and/or look in your $NTUninstall... folders (dir /s ntfs.sys from c:\windows\system32) and copy an older (but preferably not too old) version.

You can probably also download SP3, extract it, and expand NTFS.SYS from there (and you might have "backups" in the DLLCACHE or ServicePackFiles folder

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .