Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I mirror my Web site on my laptop, and am trying to move the mirror site to a new laptop. I copied the files to the Inetpub directory, and can view them perfectly, but they are read-only (the check-mark is grey, not black), and I cannot change the permission.

When I un-check the read-only attribute on the Inetpub directory, and click "apply" it displays a dialog box stating that I need administrative permission to change the attributes. (I am logged in as an administrator). When I click "continue," it pops up another dialog box saying access is denied to the attributes of the file:

c:\inetpub\custerr\en-us\500-100.asp

That dialog box has an "ignore" button, and if I click that, it appears to work through the directory tree setting the permissions. It leaves all of the files (leafs) set to "read-write," but the directories remain "read only."

I am using 64-bit Windows 7.

I stopped the IIS service while doing all of this.

Might it have something to do with the fact that I copied the files from a different machine in the workgroup (my old laptop)?

share|improve this question

2 Answers 2

up vote 2 down vote accepted

You may have to take ownership of the files.

  1. Right click on the file/folder
  2. Go to properties
  3. Go to the security tab.
  4. Click on Advanced.
  5. Pick the Owner tab.

If you, or "administrators", are not the "Current owner", you'll have to replace the permissions. Click Edit, select yourself, check the "Replace owner on subfolder" box, and hit "apply. That should overwrite all permissions on the files.

If it still doesn't work, turn off the limited admin mode for UAC. You can find directions here:

http://superuser.com/questions/83677/disabling-uac-on-windows-7

Use method 2 to set the "EnableLUA" registry setting. That will make your admins always run as admins. If you can't take ownership at that point, you may need to copy those files out to a non-system folder.

The final move is to move the files to a fat32 partition (like a thumb drive). That will strip out all NTFS permissions.

share|improve this answer
    
That did the trick! Muchas Gracias. Larry Press –  user10321 Jun 14 '10 at 23:57

You're looking at the checkbox on the General tab in the Attributes section. This is the wrong checkbox. It's a carry-over for fat32 file systems and doesn't really apply to your Windows 7 system anymore. That's why it's in that third middle state rather than fully checked or unchecked.

Rather, you need to look at the permissions listing on the Security tab of the same dialog.

share|improve this answer
    
I had also set them all to "full control," but it was not sufficient until I took ownership. You would think Microsoft would drop the FAT carry-over rather than show it as grey with a check mark -- if I understand what you are saying correctly, that is super bad UI design. –  user10321 Jun 15 '10 at 0:27

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.