Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

So here is my sorry story of woe.

My PC has been functioning normally for some time.

Last week I bought a cheapish powered USB hub and plugged it into my home PC, which runs Windows 7.

This weekend I plugged that hub into my home PC. At some stage I hibernated the PC. Then later on I plugged my Kobo eReader into the hub to charge.

Later on I started the PC up. Only thing is, it now won’t start up. It just powercycles on for a second and a half with the fans at full, then powercycles off. Then back on for two seconds, then back off. There’s no display at all and it won’t get to the BIOS screen.

It looks like anything USB is not functioning — the keyboard and mouse are not lighting up etc.

I’ve taken out the BIOS battery and reseated the RAM, reseated the graphics card and so on, but my suspicion is that I have blown the USB section of the motherboard somehow. Suggestions?

All else failing, where is the best place to take this machine in Sydney to get evaluated? It’s a fairly powerful beast, all up has cost me about $2500 over the years, including upgrades and a recent new graphics card, so can’t just start from scratch.

share|improve this question
    
what's happening is you're calling it a PC and it's getting angry –  barlop Sep 11 '11 at 19:18

3 Answers 3

First, make sure no USB devices are connected and try it just for good measure.

I'd put my money on either the:

Power Supply - Caps (capacitors) are the most common failing part of a power-supply. If you look inside the power-supply (through the vent grates) you'll see a bunch of little cans. If one looks like it's about to pop (like a pop can that blew out the bottom) that's most likely your problem.

The easy way to test to see if that's the problem is to swap it out with a functional power supply.

Processor - There's a smaller chance that this the issue but it would explain the power cycling. Often times, the heat sink (for whatever reason) unseats itself from the processor causing the processor to overheat. When a processor overheats (only takes a couple of seconds) the MOBO hardware fault protection will detect it and immediately cycle the power. The computer will usually continue to power cycle over and over until you turn it off.

Also, while it's open look around closely for scorch marks on the MOBO especially around the areas where the USB ports in question connect to the PCB. I've seen a faulty USB device do terrible things to a MOBO. If you can't see any, smell around. There's no mistaking the sound of burnt silicon.

If the MOBO is toast you will definitely need to replace it, possibly, along with the power supply.

Good luck.

share|improve this answer

Sounds like you have a few issues here

First: - Do you have another machine in the house that you can use as a donor? - Unplug all unnecessary things from the machine, like hubs, additional pci cards etc. - boot the machine, if the same thing happens then..

Power cycling: I'd swap out the power supply first to see if that fixes the issues. Could be that one of the components has fried, and when it requires too much juice it shuts it self down.

USB I've also had this issue on a new machine. Originally thought it was the OS. Found a trick on the net where you unplug the machine for an hour or so. I did mine over night, and the USB magically starts working again.

Hope this helps

Ak

share|improve this answer

Try removing components and see if you get a beep, remove ram, video, etc.. you should get status codes via the pc speaker at least, also I would start with the power supply.

If it is a USB issue (from my experience) looks for scorch marks around the southbridge (if it is the southbridge that handles your USB). I seen two machines that had light scorch marks from the USB header getting fried (improperly plugged in usb shorted out the ports, etc).

Technically you don't need to replace all of the $2500 components that you have, you might just need to replace the PSU or MOBO. But I am just guessing here at what the cause could be.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.