Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I kind of screwed up the Apache "stuff" on my Mac. Usually when I visit http://localhost/, I would see the "It Works!" but now it just lists the directory and files inside /Library/WebServer/Documents.

When I try to stop/start/restart the server with sudo apachectl stop, I get:

httpd: Syntax error on line 68 of /etc/apache2/httpd.conf: Cannot load /usr/libexec/apache2/mod_disk_cache.so into server: dlopen(/usr/libexec/apache2/mod_disk_cache.so, 10): Symbol not found: _apr_file_info_get$INODE64\n  Referenced from: /usr/libexec/apache2/mod_disk_cache.so\n  Expected in: flat namespace\n in /usr/libexec/apache2/mod_disk_cache.so

I don't want to do the MacPorts install, I tried it earlier but... I just want to do it via source code with the usual ./configure, make, make install.

Any ideas on how to get this working? Is there a way to totally remove Apache and then reinstall a fresh version?

share|improve this question
    
Have you tried commenting out the offending line in your /etc/apache2/httpd.conf first? – Gav Jun 22 '10 at 16:18
up vote 0 down vote accepted

I ended up backing up all of my files, erasing and re-installing Snow Leopard, and Apache was back to normal.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .