Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've got a Windows 7 machine that is locking up randomly. It can be in the first thirty seconds, or it can be hours later. There is nothing specific I can find that is running when it happens. When it locks, the screen doesn't change, but nothing moves. The waiting icon stops, the mouse stops, keyboard doesn't work, etc. I've even tried the crash on ctrl-scrl registry hack, and it won't even dump the kernel. I've run hardware diagnostics on the RAM and it doesn't find any problems. I would think it is a hardware issue, but on this exact same machine, I can run 64 Bit Ubuntu and it has zero problems. I've even tried reinstalling Windows7 from scratch, and it still happens.

Anyone have any ideas? Any good diagnostic tools to recommend?

Edit: 15Jun - The machine is my home built machine from various parts. It has a Gigabyte MA790X-UD4P motherboard, corsair RAM, NVidia video. It was running like a champ until my HDD took a dump. I had to send it back to Seagate and I went to Fry's to get a new one. I put the new drive in, and loaded Win7 on it. That's when it started locking up. But like I said, it runs without issue on Ubuntu 10.04.

Edit: 17Jun - Well, I removed two sticks of RAM and only left 4GB, and it hasn't crashed on me yet. So I'm thinking that it had something to do with a RAM mismatch. Even though MEMTEST passed with flying colors, it fixed it.

Next step is to try and add a couple more 2 GB sticks instead of the 512's that I had in there.

share|improve this question
    
Did this machine come with Win7? How old is the machine, and is it a standard vs. custom build? –  Argalatyr Jun 15 '10 at 3:27
    
I was having similar problems with Win 7 x64, for now I back to using x86 as my main desktop whilst I try and find a solution that works for more than a few days. There is a huge thread here social.answers.microsoft.com/Forums/en/w7repair/thread/… Not an answer, I'm afraid :( –  Pulse Jun 15 '10 at 3:41
add comment

1 Answer

one thing to try (if you can get to it in time) is Microsoft's Fix-it Center http://fixitcenter.support.microsoft.com

if that doesn't work I would try taking the memory out then putting it back in again

share|improve this answer
    
I'll try that, thanks. I'll post how it goes. –  Teejeaux Jun 16 '10 at 0:14
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.