Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

The plot is quite simple. Got a Razer mouse. If I plug it in, it works. After a shutdown/hibernation, I have to replug it entirely at the back of the PC. (It works in my laptop even after several shutdown, etc, so yes I guess it's my motherboard.. but it still got 2 years of warranty and it comes with quad SLI, its not an old motherboard at all. (MSI P7N SLI FI (bought it after a Hungarian guy's recommendation)).

So. I only could come up with one "solution". Get 3 USB cable (you know, USB-USB). If its possible the shortest ones (don't know if the responsibility/anything will worsen), AND replug only the middle+closest to the USB port junction, since those are replaceable.

What do you think? Any other idea? (BIOS is updated, mouse driver ... doesn't really matter, the mouse won't even blink a bit after this happens. It lights up and goes totally dead.)

share|improve this question

2 Answers 2

up vote 1 down vote accepted

If you have 2 USB on the front of the box and 4 on the back, those 4 are probably ganged through a USB hub. According to specification, there should be no difference between a hubbed port and a direct one, but in practice there often is and it manifests in exactly the manner you describe. But I find that the problem lives with the peripheral not the port (that is, take the same cheapo MP3 player to another hubbed machine and it still fails while a printer in the same ports would work fine).

That said, you can

  1. Try plugging the mouse in front
  2. exchange the mouse for an identical one which is up to spec
  3. do the cable trick you propose

This doesn't mean that you can say the mouse is bad, it could be drivers or it could be pull-up transistors in your USB hub.

share|improve this answer
    
Nice idea, will try to plug it in the front. =) ty. –  Shiki Jun 15 '10 at 7:52

If it turns out that the sockets you're using are bad, then you might be able to get a PCI card with USB sockets on it (I haven't had to look for one of these for a long time but I assume they're still available and still reasonably cheap) to replace the onboard ones that have gone.

Otherwise as msw suggests it could be dodgy drivers. Try using Linux from a Live CD (I assume it's a windows machine), and see if you can get the same error to reproduce (ie use it, reeboot and use it again).

You may be able to download a USB monitoring program of some kind to see if you can detect a problem.

What happens if you plug a pendrive (or some other piece of hardware) into that port? Do you have to replug those too after a reboot?

share|improve this answer
    
Linux, BSD, everything have this problem. It's like it dies right after at boot. (Other things work. Even after several reboot.) So the OS is not a problem. –  Shiki Jun 15 '10 at 10:01
    
When you say other things work, do you mean stuff like pen-drives? –  Amos Jun 15 '10 at 12:41
    
Yes. Also keyboard, external hdd, card-reader, everything. (Still no advancement, didn't have time to took my PC apart. I hate to cable the front panel so yeah. Will do it today. :)) –  Shiki Jun 16 '10 at 6:48

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.