Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I work in two different locations and whenever there is a power outage at one of the locations, Windows 7 detects that the system was improperly shutdown. Once the power is up, the PC powers on and Windows 7 enters REPAIR/SAFE mode where only someone physically in front of the PC can control it. (Networking is all disabled in this mode)

Now before it enters REPAIR/SAFE mode, there is an option for a NORMAL boot. But the catch is that REPAIR/SAFE mode is selected by default with a 30 second timer. Once it automatically enters REPAIR/SAFE mode and if nobody is at the other location, I have no way to remote control it anymore. And then I have to drive over to the other location and reboot it and select boot into NORMAL mode.

Where can I change this setting so that Windows 7 always boots into NORMAL mode no matter how many times it is improperly shut down?

share|improve this question
3  
Have you thought about investing in a UPS for the PC at the remote location? If power cuts are frequent it will pay itself back in the time you don't have to spend resetting the machine. –  ChrisF Jun 15 '10 at 12:14
    
Tks for the comment. This will only work if the power is out for a brief period but what if the power is out for 1-2 days? I'm stuck with a PC in SAFE mode in a remote location with no one to control it. –  Level1Coder Jun 15 '10 at 12:41

3 Answers 3

This has been quite the difficult question. There doesn't seem to be much of anything out there. The only viable solution out there seems to be the following.

WARNING: This can damage your system, use at own risk.

First run a command line window as administrator.

Start Menu > All Programs > Accessories > (right-click & "Run as administrator") Command prompt

next run the following commands

bcdedit /export C:\BCDbak

This will make an export of your Boot Configuration Data Store. You can import it with

bcdedit /import C:\BCDbak   
bcdedit /import C:\BCDbak /clean  

You can now try to disable recoverymode with the following command.

bcdedit /set {default} recoveryenabled No

This answer may work for you, but I certainly recommend that you invest in a UPS for this sytem.


EDIT: You can also display your configuration by running

bcdedit /enum

and

bcdedit /enum /v
share|improve this answer
up vote 3 down vote accepted

I just had a nasty power outage and gruntled's answer did not fully solve my initial concern 2 years ago. Because of an initial misconfiguration, I am now booking an expensive plane trip back to the staff-less server room in the other country just because of a simple boot problem. (no hard feelings)

After doing some more research online and to extend gruntled's answer it seems the correct settings for bcdedit should be:

bcdedit /set {default} bootstatuspolicy ignoreallfailures <-- Newly added setting

bcdedit /set {default} recoveryenabled No

If I don't get any more problems in the future with this setting, I'll keep this as the answer. Hope I saved some lucky person the cost of a plane trip ride back to fix a simple boot problem.

share|improve this answer

Instead of ignoring all failures, you can ignore shutdown failures only:

BCDEdit /set bootstatuspolicy ignoreshutdownfailures

See this MSDN article. If you run BitLocker with TPM key protection, be aware that the TPM will detect the BCD change and refuse key release to Windows. Therefore, make sure to re-seal the key before rebooting.

Manage-bde c: -protectors -disable
Manage-bde c: -protectors -enable
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.