Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I need a pop3 email account setup that does not have the @domain.com in the username. It's for a piece of software that I am using that does not like seeing @domain.com in the username for setup. Any idea's? The account only needs to be accessed locally.

share|improve this question
    
what operating system(s) are you using? by "locally" do you mean "on the same LAN" or "on the same computer"? –  quack quixote Jun 15 '10 at 12:47
    
Using windows xp. On the same computer will be fine for now. I am using a clumsy piece of software that needs to have data inputted by pop3 email. –  Richard Jun 15 '10 at 12:51
    
Before starting to look at solutions that involve you changing mail providers, I would personally take a look at the software documentation or ask the developers (or tell us the software and someone may be able to help). It may be as simply as putting brackets, quotes or an escape character of some sorts before the at symbol or similar. –  William Hilsum Sep 8 '10 at 1:29

2 Answers 2

up vote 0 down vote accepted

Gmail supports POP3 logins without the domain part. (Except for Google Apps users, of course.)


If your "clumsy piece of software" does not support SSL encryption either, this can be handled by stunnel in client mode:

[gmail-pop3]
client = yes
accept = 127.0.0.1:1234
connect = pop.gmail.com:995
share|improve this answer
    
I think this may be the problem. I tried Gmail and still no dice. I will give stunnel a go tomorrow and see what happens. I will post a reply once I try it. –  Richard Jun 15 '10 at 18:49
    
Still no dice. I copied and pasted your code above into the stunnels .conf file and still have not had any success. –  Richard Jun 16 '10 at 11:42
    
@Richard: Did you not forget to start stunnel and change your program's settings to use 127.0.0.1 port 1234 as the POP3 server? –  grawity Jun 16 '10 at 14:58
    
I did and it is started. I will check with the software manufacture and see what is going on. When or if they get back to me I will let the forum know. –  Richard Jun 16 '10 at 16:52

Try sending it to user@[127.0.0.1]

You need to use the [] to specify this is being sent to an IP.

If that does't work, you could change the HOSTS file to map DOMAIN to an IP where the mail server could sit. For example, mail@DOMAIN, and DNS would then understand DOMAIN to goto some IP.

The only problem now is setting up your pop3 to accept this mail into a proper inbox.

If you mean you want to send email to "user" and not user@domain or even user@, you can't pull this off. You need that @ sign, unless you're going to write your own SMTP layer.

share|improve this answer
    
I believe the question is about the username used when authenticating to a POP3 server -- not about sending mail. –  grawity Jun 15 '10 at 18:33

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.