Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I need flash to watch YT videos. YT said "You need to upgrade your Adobe Flash Player to watch this video." with a link to download flash. I'm running 10.04 so I see possible choices for myself: 1) a .deb file for Ubuntu 8.04+ or APT (whats this??) for Ubuntu 9.04. I downloaded the deb file and when I opened it in the installer it said that I have the wrong architecture. Anyone have an idea about how to work around this?

share|improve this question

2 Answers 2

up vote 2 down vote accepted

Ok I found it. I have to use synaptic to install flashplugin-installer. Its works now!

share|improve this answer
    
Lucky you, when I used 64-bit Ubuntu on the old days of 7.04 I had to go throught all the hassle of installing 32-bit Firefox with all the plugins, after which not even half of it worked. –  Martín Fixman Jun 16 '10 at 1:25
    
boo! Yeah that sucks. Well I had Ubuntu running on this machine for a while (9.04, 9.10 etc) and I had flash working then. I guess I just forgot what what I did in the first place to get it going. –  DJTripleThreat Jun 16 '10 at 1:37

If you enable Canonical's partner repository, you'll also find the packages adobe-flashplugin and adobeair in your package manager.

To enable this extra repository:

  1. Open System > Administration > Software Sources
  2. Go to the "Other Software" tab
  3. Check the box next to this line:
    http://archive.canonical.com/ubuntu lucid partner

Now you'll need to update/refresh your package manager (sudo aptitude update on the commandline, or the Reload button in Synaptic), and these packages will be available.

share|improve this answer
    
+1 for adobe air. I didn't know that! –  DJTripleThreat Jun 16 '10 at 19:23
    
I did as you said but those packages don't show up. If I click the "Origin" button in synaptic, what would the repo be named there? –  DJTripleThreat Jun 16 '10 at 19:34
    
@djtriplethreat: i don't use Synaptic very often, but it looks like the lucid/main (archive.canonical.com) entry is where you'll find those packages. if you aren't finding them, either they aren't available for your architecture or you haven't enabled the correct repository. i'm not using a 64-bit architecture so your package list may differ. –  quack quixote Jun 16 '10 at 21:08
    
Ok, I think they aren't available for 64-bit architecture. Thanks for the help though. For 64-bit architecture I'll have to go with what I found because it works for my question. –  DJTripleThreat Jun 19 '10 at 12:06

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.