Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I was having a bit of trouble reading the dark red strings of Vim's default color scheme, so I decided to switch to a different one.

http://code.google.com/p/vimcolorschemetest/source/browse/colors/blackboard.vim?r=2

http://files.werx.dk/wombat.vim

However, when I set my color schemes to these, not only do they not come out correctly (for example, comments are bright blue), but these 2 somehow come out looking exactly the same!

Am I doing something wrong, or are these colors restricted in the terminal so default colors are being chosen?

share|improve this question
    
The first link (code.google.com/...) is a 404 for me. –  Stefan Lasiewski Jun 16 '10 at 2:50
    
@stefan it is fixed. –  person Jun 16 '10 at 3:12
add comment

1 Answer

up vote 0 down vote accepted

Couldn't load the first link. The second link changes the colors for the gui (i.e., for gVim) only, not the colors for vim in a terminal

Look up the docs for the 'highlight' command, which will show you that guifg and guibg are options that set the color for text foreground and background in gVim, and ctermfg and ctermbg are the corresponding options to set colors in terminal vim.

So if you wanted to make Comments in both terminal and gui versions have the same colors you might issue a command like this:

  :hi Comment ctermfg=Cyan guifg=Cyan ctermbg=black guibg=black
share|improve this answer
    
I'm trying CSApprox right now. Will see how that works. –  person Jun 16 '10 at 3:13
    
Meh, I"ll just edit it myself. –  person Jun 16 '10 at 3:22
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.