Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to make a custom trigger for my shell/apple script file to run so I can just launch my dev environment at the push of a button. So basically:

  1. I have a shell script(and some apple script included) in ~ named start_server.sh which does 3 things:

    • start up solr server
    • start up memcached
    • start up script/server
  2. I have a saved quicksilver command(.qs) that opens up start_server.sh(so start_server.sh, then the action is "Run in Terminal")

  3. I created a custom trigger that calls this saved qs command.

I did that then tested it and it works. I then tried to double check it so I quit quicksilver and when I checked the triggers it just said: "Open (null)" as the action. I set the trigger again and when i restarted QS the same thing happened again. I don't know why but my old custom trigger to open terminal has worked since forever so why doesn't this one work?

Here's a screenie of the triggers after I restart QS:

enter image description here

If you have any other suggestion on how to make a "push button" start for my server then please do so :) Thanks!

As an added note, I have already tried the steps on this thread but to no avail: http://groups.google.com/group/blacktree-quicksilver/browse_thread/thread/7b65ecf6625f8989

Here's a snippet of the supposed custom trigger in the Triggers.plist file:

<dict>
  <key>ID</key>
  <string>2903BB6B-94CB-4DE8-B00D-23973FA54F3D</string>
  <key>command</key>
    <dict>
  <key>actionID</key>
  <string>FileOpenAction</string>
  <key>directID</key>
  <string>/Users/eumir/Documents/QScripts/start-dx-command.qscommand</string>
</dict>
  <key>enabled</key>
  <true/>
  <key>keyCode</key>
  <integer>39</integer>
  <key>modifiers</key>
  <integer>1573160</integer>
  <key>onPress</key>
  <true/>
  <key>type</key>
  <string>QSHotKeyTrigger</string>
</dict>

Took out spaces in the folder and filename and it still returns null upon restarting.

share|improve this question
1  
Since Quicksilver is being (quasi-)abandoned by its developer, I'd suggest you check out Alfred; it's a very viable & functional alternative to Quicksilver. –  squircle Jun 16 '10 at 21:13
    
hm interesting but im already comfortable with qs. still i'll try this out and see if i can incorporate this with my lazyness. thanks for the tip! –  corroded Jun 17 '10 at 5:36
    
just tried this app. Alfred doesn't have a means to creating custom triggers like qs though. –  corroded Jun 17 '10 at 7:06
    
This was a bug in previous QS versions. I suppose it's fixed a few month ago. btw QS is still in active development, checkout qsapp.com –  freewizard Feb 14 '12 at 19:44

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.