Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I installed Windows 7 on VMWare and it works just fine! However, when I leave the machine idling and work on my host OS, Windows 7 decides that it is a good idea to thrash disk and kill performance. How do I disable these background processes? Is it just indexer?

share|improve this question

migrated from serverfault.com Jun 16 '10 at 13:09

This question came from our site for professional system and network administrators.

    
I think you mean "thrash". Trash is more of a "destroyed my data" thing. –  Bart Silverstrim Jun 16 '10 at 12:55
    
It's possible it's the indexing service; which can be set to disabled in the Services MMC. –  Chris S Jun 16 '10 at 12:56
    
Workstation troubleshooting is in a gray area that currently rests on SF. Other questions there, such as superuser.com/questions/32860/… may already have what you're looking for, too. –  Kara Marfia Jun 16 '10 at 13:09
    
FYI thrashing to me means heavy swapping when low on memory (to "thrash" back and forth). –  StuffMaster Oct 15 '10 at 19:11
add comment

2 Answers

up vote 1 down vote accepted

I'd first run sysinternals' procmon tool to see what is hitting the drive, or filemon. That should narrow down what process is first causing the disk thrashing, and from there decide what to do.

It is most likely a search index. If so, I'd try increasing RAM first of all to the VM if at all possible, then let it finish the indexing and it should be better after that. If that doesn't alleviate the issue then I'd start googling for how to turn off the search indexing on Win7. If you find with the sysinternals tools that it is most likely the search indexing causing issues then come back and ask about it (or see if it's already in SF or SuperUser) and see what solutions are available, as I'm right now assuming from the question that you need to find out what is causing excessive disk thrashing.

share|improve this answer
    
I will try it next time it does it and report back –  Konrads Jun 17 '10 at 6:37
    
I guess this was what happened.I've never seen it thrash disk again after I let it churn for a while. –  Konrads Jun 18 '10 at 12:35
2  
Okay, i found the culprit. Using procmon from sysinternals i noticed that rtvscan.exe was most active - Symantec Endpoint Protection. Disabling it reduced disk activity to idle. –  Konrads Jun 28 '10 at 10:57
    
Search indexing can be turned off like this: Start > services.msc Look for service called Windows Search. A drop down menu then allows it to be set to Automatic, Manual, or Disabled. –  Assad Ebrahim Sep 1 '12 at 5:27
add comment

I had similar disk thrashing issues, I found that applying these tweaks it has calmed my disk thrashing a bit: Tweak settings in VMWare

  • Disable "Take snapshots in the background"
  • Disable "Restore snapshots in the background"
  • Disable "memory page trimming"
  • Create a separate virtual disk for the windows paging file

And of course disable windows search indexing in both the host and the guest OS.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.