Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

when launching chrome from the windows command line I can pass arguments like so:

...>chrome.exe -incognito

I can also pass a URL to open

...>chrome.exe google.com

Each work fine on their own but I can't get them to work together.

What I want is to launch it with a url, and open in its OWN tab, and hide the url, buttons, etc. like a utility window but I do want it resizable.

share|improve this question
add comment

3 Answers 3

up vote 16 down vote accepted

You might want to try and give it another try. I just tried it with the following command

chrome.exe google.com -incognito

This gave me the following window, notice that it is in incognito mode (little icon on top left) and it is also at google.com (or whatever url you pass). It works, maybe you were just typing it in wrong.

If you have a window open Chrome will default to the currently running application and add a new tab to that, it saves time (of app startup) and memory. In this case, try

chrome.exe -incognito --app=google.com

alt text

share|improve this answer
    
Maybe there is something wrong with my installation then. I copied your text and pasted it into my cmd. All it did was add a tab in an already open window (not incognito) and go to google.com. If I remove the google.com part, it opens a new incognito window.... However, if I have no open windows of chrome, it works as desired so I guess the problem is having already open windows. Try it yourself. –  JD Isaacks Jun 17 '10 at 14:49
2  
Yes, if you have a window open Chrome will default to the currently running application and add a new tab to that, it saves time (of app startup) and memory. try chrome.exe -incognito --app=google.com –  Daisetsu Jun 17 '10 at 17:04
add comment

FWIW, here is the Mac version, you can put this in your .bash_profile file:

##Launch Chrome with given URL from commandline
alias url="open -a /Applications/Google\ Chrome.app"

Run the following command for it to take effect:

>source ~/.bash_profile

Usage:

>url http://www.twitter.com

Note: Yes, you have to put "http://" in front of it. Otherwise, it thinks you're passing in a file.

You can also include the http part in the command (you will have to do https as well I suppose):

alias url="open -a /Applications/Google\ Chrome.app http://$1"
share|improve this answer
add comment

I had the same issues trying to open an incognito browser to a specific page. Here's how I got it working:

chrome.exe -incognito --new-window mytargetpage.com
share|improve this answer
    
This solution worked better for me when setting up Chrome as an external browser in Eclipse. –  Snekse Jan 26 '11 at 16:30
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.