Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

So I went to install about 5,000 new fonts on my Windows 7 64-bit machine. It was slow to install them, and I had to leave. I came back and my PC was shut down, and I had to go through the Windows recovery BS when I powered it on. Now my computer runs extremely slow and any program that has a font menu locks up my whole machine (nothing in Microsoft Office works). When I go to "Fonts" in the control panel, it says 0 items. I went through all of the font settings trying to get them to appear. Nothing helps. I tried to bring up the Character Map and that froze up my machine too.

How can I fix this?

If I do not get this issue resolved soon, I am wiping this drive and going back to XP (and probably never purchasing another version of Windows again). I never had any issues with XP and have had nothing but performance problems when switching to Windows 7. My quad-core intel extreme with 8GB of RAM should never flinch with the kind of work that I do, and something simple like playing a song off an external HD takes up to five seconds on Windows 7. Unbelievable that I had to pay for this crap!

share|improve this question
So I went to install about 5,000 new fonts... there's the problem... Maybe you could use a Live-CD to delete some fonts. – Bobby Jun 16 '10 at 15:45
There could have been a problem during the font installation such as a power failure or hardware failure. In this case the font's wouldn't have finished installing and rebuilding the cache, this is probably why fonts don't show. Just revert to your last backup and copy any missing files manually. – Daisetsu Jun 16 '10 at 15:46
@Bobby That is a ridiculous comment; there is nothing absurd about having 5,000 fonts. I know designers that have over 30,000 fonts installed on their Macs. It is not 1995. Move on if you don't want to help me out. – Josh Stodola Jun 16 '10 at 15:46
Doing a System Restore corrected the problem. I wonder if it was a corrupt font or if I had a power failure in the middle of installation. In either case, Windows 7 did a very poor job of handling the situation. – Josh Stodola Jun 16 '10 at 16:14
Josh, please make your solution into an answer and accept it, to close the question. Incidentally, your "It is not 1995" is misguided. Windows font management is not comparable to Mac, and is in fact very poor by comparison. All fonts in the Fonts folder are loaded into memory at startup. That's your problem right there. – user3463 Jun 16 '10 at 16:26

Windows keep track of installed fonts in registry.

Possible your registry got corrupted when your PC shut down. Try using a registry cleaner like RegCure and make some fixes.

share|improve this answer
up vote -6 down vote accepted

Windows can't handle fonts. I had to do a system restore to get my machine to be functional. If you want a variety of fonts, you must switch to a different operating system such as Mac OSX.

share|improve this answer
windows is able to handle fonts. It just doesn´t work the same way it does on Mac. I found this (…) about the new "Install fonts" button. But I would sugest you try copying them manually into the fonts folder. – Diskilla Jun 17 '10 at 13:35
@Diskilla That is exactly what I did. It started to install, and when I returned a few hours later the machine had shut down unexpectedly. I know it was not a power failure because my web server did not flinch. I tried the same thing several times with the exact same result. Conclusion: Windows has a font limit that is not enforced. – Josh Stodola Jun 17 '10 at 19:53

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .