Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an odd problem with a windows 7 laptop. It's a single user installation currently. This is a fresh install on an Asus laptop.

I have a svn repo checked out on my second partition. I have a directory which I have added to svn:ignore list, because it is for tmp files. This specific directory shows as read-only. I need write access on this directory for my project to function properly.

If I right click and modify the directory to be not be read only and run this recursively, it simply is immediately reverted back to a read-only directory.

I have also modified apache's service to run as myself to no avail.

I'm stumped... Any ideas?

share|improve this question
    
According to: support.microsoft.com/kb/326549 It looks like this isn't a problem -- modifying the permissions though in my steps below has alleviated my problems. –  Scott Jun 18 '10 at 13:56

4 Answers 4

When you check out a SVN repository, try to get the writable one. E.g., Google Code offers read-only anonymous SVN repository and authenticated read-write repository links.

share|improve this answer
    
I have authentication for read/write on the project. Have no problems with any other files / directories. –  Scott Jun 16 '10 at 18:33
up vote 1 down vote accepted

This likely isn't the "safest" solution, but it has "alleviated" my problem:

  1. Hit properties on folder.
  2. Select Security Tab
  3. Click Advanced Button
  4. Click Owner Tab
  5. Click Edit
  6. Click Other users or groups
  7. In the enter object name to select: type Everyone
  8. Check the box: "Replace owner on subcontainers and objects
  9. Click OK
  10. Click Permissions
  11. Click Change Permissions
  12. Ensure Everyone has Full control
  13. Check: "Replace all child object permissions with inheritable permissions from this object"
  14. Click OK on all remaining dialog boxes

The UI still shows that the directory is read only when I select properties again, but I'm able to read/write to the directory and its subdirectories after taking these steps...

share|improve this answer

In Windows7, administrator account is hidden. You can enable the administrator account.

  1. Click start
  2. Program - Accessories- Right click on command prompt and select " Run as" administrator.
  3. In command prompt type command type net user administrator /active:yes

It will cure it. you will 2 user account one is administrator and your user. Now you can login to windows as administrator. Now you will modify the files or even delete it.

share|improve this answer
    
I don't think there is a need to enable that account to do this, since I can effectively run attrib as the administrator from the Run as cmd window. Even running attrib -r on the directory recursively the UI still shows as read only. –  Scott Jun 18 '10 at 13:58

Check the "ownership" of the folder in question, you may need to take ownership of it.

http://www.blogsdna.com/2173/add-take-ownership-option-in-right-click-context-menu-of-windows-7.htm

Once ownership has been taken, check the Properties>Security Tab of the folder to be sure you have write permissions.

share|improve this answer
    
I already had ownership of this, as I am the only user on the machine, in my "answer" I changed the owner to everyone. –  Scott Jul 1 '10 at 14:54
    
Yes, but did you double check write permissions. –  Moab Jul 1 '10 at 22:11

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.