Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I inadvertently set the Registry Editor to be the default editor for *.txt files. Now when I go to change the default, "Always use this program to open these files" is grayed out. This is the case whether I right click on the file and choose "Open with...", or start with the "Set Default Programs" control panel.

alt text

Why? How can I fix this?

share|improve this question
1  
Is it grayed out just for notepad, or for all programs? – nhinkle Jun 17 '10 at 6:20
1  
It's grayed out for all programs. – Herb Caudill Jun 18 '10 at 19:14

In case anybody is still having this issue, it's worth checking if you have the File Association Helper installed. It's included as a part of the WinZip package and overrides the default settings for how you deal with files, resulting in the greyed out "always use this program" box. Just uninstall it and it will go back to normal.

share|improve this answer
    
Uninstall WinZip? Great idea! It really sucks! – Octopus Jan 13 at 7:25
up vote 23 down vote accepted

I came across this problem again, but in this case the file association fixer tool suggested by @Moab didn't work because it only handles a handful of common extensions, and the extension I was having trouble with (.ahk) isn't included.

I did some more digging and found a general solution using regedit; this did the trick for me.

  1. Open regedit
  2. Go to HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts
  3. Find your extension
  4. Delete the UserChoice key
share|improve this answer
1  
Thank you!! Now I just wonder how the heck this happend in the first place. – thnee Jul 19 '13 at 20:08
    
This happened for me just after using mplayer to open a file of the same type. Might be a coincidence though. – persiflage Jul 4 '14 at 11:43
    
Thanks for your help! :) In my case, the problem occurs with WinZip. And you know what? The checkbox came to gray immediately after installing WinZip and the default program is now WinZip to handle .zip files. That mean WinZip is changing the default program without asking me and worst, they change the registry key to prevent user changing the default program to handle zip file. With your help, it's fine; I will be able to rollback this behavior but for people like my mother, no way she will be able to understand what's happening and she will stay with /"$/$/%%% WinZip! – Samuel Sep 16 '15 at 14:15
    
Right. Mplayer! I had this issue with avs files. Every time I delete the key it works fine for all other apps until i once again associate it with mplayer and bang, grayed out again! I don't mind using mplayer except that as soon as I do I can no longer associate that file type with anything else any more. Even my usual media players. – Octopus Jan 13 at 7:22

Assuming you are logged in as Admin, first thing to check is the Windows Registry.

  1. Open Registry Editor (Start > Run > regedit) and navigate to

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\policies\Explorer

  2. In the right side of the screen double click on "NoFileAssociate".

  3. Change the value of "NoFileAssociate" from 1 to 0.

  4. Now navigate to

    HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\policies\Explorer

  5. Repeat steps 2 and 3.

  6. Close "regedit" and reboot your machine.

If the above procedure doesn't work for you (or if you already have "NoFileAssociate" values as 0), reboot in safe mode and change a filetype to be opened with a default program (or right-click and select "open with" for that file type, and check if the box is still grayed out or not) and hit OK. In the next reboot, the issue should be fixed.

share|improve this answer

Check If you've unticked the hide file extensions for known file types In the folder options. You may have this unticked and when renaming a file you also removed Its extension.If you know the file type and add the extension (eg .doc for word) the option shouldn't be greyed out anymore.

share|improve this answer
    
Having an unknown extension doesn't do what you say. Try opening a command line, go to your desktop folder and do echo rats > rats.rats. Now go to your desktop and double click. – Isaac Rabinovitch Nov 24 '12 at 20:14

Use this file association fixer tool

http://www.addictivetips.com/windows-tips/fix-windows-7-file-association/

.

share|improve this answer
    
That worked like a charm - thanks so much. – Herb Caudill Jul 4 '10 at 1:24
    
You are welcome – Moab Jul 4 '10 at 15:16

protected by Community Dec 22 '14 at 20:44

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.