Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

In the last week, clicking on links from within Outlook email messages stopped working. The links appear clickable, but clicking them doesn't do anything.

How do I fix this?

share|improve this question

2 Answers 2

up vote 2 down vote accepted
  • Is it possible the target of these links is being changed to blocked:http://link.target by security settings somewhere, and thus nothing is happening? Try checking your security options in Outlook to make sure this isn't happening.

  • Open up a Start->Run box and type in some URL. Make sure it actually opens up a browser to that address. If not, something is swallowing up these requests; try resetting your default browser.

share|improve this answer
    
Your second suggestion was it - this has nothing to do with Outlook. Running a URL from Start->Run doesn't work. The default is Chrome, but the problem is a bit different: superuser.com/questions/153609/… –  ripper234 Jun 17 '10 at 10:21

I also have a problem with links not working on Outlook 2003. I have IE 8 on Windows 7. IE 8 is my default browser and typing urls in Start -> Run does go to the url.

When I click on a link an in Outlook email a new IE session fires up but it just goes to the default home page, and not the url in the link.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.