Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

whenever I run emacs or emacs23 on terminal I just get the following output:

** (emacs:2620): CRITICAL **: menu_proxy_module_load: assertion `dbusproxy != NULL' failed

And the gui doesn't load, and emacs' window never opens. The emacs process doesn't actually crash (the terminal stays busy, and I can see the emacs23 process running with ps -e).

I've tried running it with the -D --debug-init arguments, but the same thing happens and the output is exactly the same. However, if I run emacs -nw it successfully runs emacs in terminal mode as if nothing were wrong.

Strangely, this problem only started happening the second time I ran emacs today. The first time it worked perfectly fine. Since then, I've tried rebooting and I've tried purging the emacs installation, to no success.

I haven't installed any new packages today, but I might have upgraded some, could that be the reason? Is there a way to find out which packages were installed/upgraded today?

EDIT: Additionally, if I run sudo emacs it loads normally and everything runs great.

Thanks

I'm running Ubuntu Lucid

share|improve this question

1 Answer 1

up vote 3 down vote accepted

Looks like you hit a known Ubuntu bug where the appmenu-gtk package seems to be broken. The solution seems to be to remove this package until this gets fixed in the repositories.

If this doesn't work don't run your emacs sudo like suggested by some people over there, rather use emacs on the command line with

$ emacs -nw

or use another editor for the time being.

My crystal ball tells me that this might get fixed not too far in the future.

share|improve this answer
    
Thanks. I'll try and be patient. :) –  Bruce Connor Jun 17 '10 at 22:28
1  
@dconnors, @honk: a comment on that bug suggests the broken packages may be coming from the Unity PPA; if you have that PPA enabled, try disabling it and reinstalling the affected packages. –  quack quixote Jun 18 '10 at 4:11
    
@quack quixote: That's possible, I think I installed the global menu applet from that PPA. I like this applet so much that I'm willing to wait a couple of weeks to see if they fix it. –  Bruce Connor Jun 18 '10 at 13:52

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.