Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I tried to download the rpm for vim from ftp://public.dhe.ibm.com/aix/freeSoftware/aixtoolbox/RPMS/ppc/vim/vim-minimal-6.3-1.aix5.1.ppc.rpm . I am using "ftp" command in AIX. when I use,

open public.dhe.ibm.com

It's prompting for username/password. But no information regarding this is given on the linked page. How do I download the rpm using "ftp" command?. Thanks.

share|improve this question

migrated from stackoverflow.com Jun 18 '10 at 4:50

This question came from our site for professional and enthusiast programmers.

3 Answers 3

The access is by anonymous but why would you like to do that?

wget ftp://public.dhe.ibm.com/aix/freeSoftware/aixtoolbox/RPMS/ppc/vim/vim-minimal-6.3-1.aix5.1.ppc.rpm

works like a charm. If you want to get knowledge then use man ftp read rfc and wiki page.

share|improve this answer
    
Well there is no wget in AIX!. I tried "man ftp" but can't find anything related to this user/pass issue. Thanks for your reply. –  wowrt Jun 17 '10 at 14:09
    
You can compile it from source... Its really useful tool. I cannot live without it. But yeah that wasnt actually a question. Sorry –  ochach Jun 17 '10 at 14:13

Use "anonymous" as username, any password will work (I just pressed the return key).

Sample session:

$ ftp public.dhe.ibm.com
Connected to dispmy-112.mul.ie.ibm.com.
[...]
Name (public.dhe.ibm.com:***): anonymous
331 Guest login ok, send any password.
Password:
230 Guest login ok, access restrictions apply.
Remote system type is UNIX.
Using binary mode to transfer files.
ftp> 
share|improve this answer

Untested, but you should be able to use:

ftp ftp://user:password@host/path/to/file

To get your file with a user/password combo.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.