Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have tried everything I can, but Pidgin chat windows do not pop-up in focus when I get a new message. The chat windows are created in the background and I always miss them.

I suspect this is a 64-bit Windows 7 issue, but I don't have a fix.

share|improve this question

3 Answers 3

Pidgin has a "New Message Notification" plugin, in which there is an option to make windows appear in foreground.

(A possible reason they don't do so by default is that it is very annoying to accidentially IM your password to a stranger who just greeted you.)

share|improve this answer
    
The Message Notification plugin was helpful, but the windows are still not popping into the foreground - although they do bring me out of fullscreen videogames. :-\ –  Iain Jun 27 '10 at 22:21
    
Same problem here, I don't care for the Pidgin windows not to disturb my workflow as I notice the flashing icon right away, but it's so annoying that a new Pidgin window tends to disturb my game. –  Tom Wijsman Jun 27 '10 at 22:48

Try this (in combination with the message notification plugin):

  • Run the 64-bit version of the registry editor. (you have to close the 32-bit version first if it's running)
  • Navigate to the key HKEY_CURRENT_USER\Control Panel\Desktop
  • Set the value ForegroundLockTimeout to 0.
  • You may need to reboot?
share|improve this answer

Pidgin is designed intentionally to not steal window focus. It would be nice if there were an option to let it do so, but currently there is not. I personally find IM clients that steal focus to be very annoying, since they distract from my workflow, but each to their own.

What you can do is configure Pidgin to set the window state to "needy" when a new message comes in. This will make the window and its taskbar icon blink until you give it focus. Usually this is enough to grab my attention. In Pidgin 2.7.0 there is a bug which prevents blinking from working properly, but that was fixed in 2.7.1, so make sure you're running the latest version.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.