Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using NetBeans in a project, making use of remote sync to save both locally and to a FTP server. This feature works in other projects, but this time is failing when trying to save the file to the remote server.

The IDE log tells me that had occurred a unknown error, as well as this :

Upload failed: org.netbeans.modules.php.project.connections.TransferInfo [transfered: [], failed: {index.php=Cannot upload file index.php (unknown reason).}, partially failed: {}, ignored: {}, runtime: 61136 ms]
    Cannot logout from server

The version of the IDE is 6.8.

Cheers

share|improve this question

6 Answers 6

up vote 2 down vote accepted

For those still having issues with this (passive mode doesn't work, version 6.9 doesn't work, etc.) you may be running into issues with IPv6 sockets being filtered by Windows Firewall incorrectly. (JDK7 and above use IPv6 sockets when IPv6 is enabled.)

See this bug for more information and workarounds:

For the "Djava.net.preferIPv4Stack=true" workaround, see this page for more information on how to configure it: http://performance.netbeans.org/howto/jvmswitches/

share|improve this answer
    
You can test for this problem by temporarily disabling your firewall locally and seeing if you can now remote sync. If this fixes your problem, follow the first link above for workarounds. –  kingliam Apr 11 '12 at 15:36

Use passive mode in your ftp settings

share|improve this answer

People having this issue may have run into the Windows 7 with JDK 7 issue:

The solution is to either downgrade your JDK or add some Windows Firewall exceptions for Java. Adding the exceptions didn't work for me, so downgrading the JDK to version 6 is my suggestion!

share|improve this answer

Even if you upgrade to Netbeans 6.9 you may have the same problem unless you check "Passive mode" in the settings.

share|improve this answer
    
It's working. I have just Checked the Passive Mode –  arnaud Jun 30 '10 at 14:50

Run command prompt as admin and run

netsh advfirewall set global StatefulFTP disable
share|improve this answer
3  
Welcome to Super User! Could you expand your answer to explain how to run a prompt as admin and what the command actually does? –  slhck Nov 8 '12 at 9:11

I Solved this problem by allowing connections For NetBeans in Windows firewall, and created a new rule to allow connections for Java/jdk.../bin/java.exe.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.