Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My computer currently has access to the internet only through a proxy, thus I'm forwarding my ssh connection to port 8080 through corkscrew.

I need to run rsync over this ssh connection - does anyone know how to make it work? Just typing "rsync username@destination-ssh-server:folder-name" doesn't work since this doesn't forward the ssh traffic to port 8080.

Thanks

share|improve this question
up vote 1 down vote accepted

I was able to do this using the command

"rsync -v -e ssh Host:remote-folder destination-folder"

where Host was a host configuration in my .ssh/config file that used corkscrew using the ProxyCommand declaration.

share|improve this answer

You can specify the port using "-p 8080".

share|improve this answer
    
The -p option I believe is for setting destination permissions to be the same as source permissions. At any rate when I execute rsync -p 8080 source destination, it thinks 8080 is a file and fails. – Opt Jun 19 '10 at 6:08

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .