Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I recently bought a Panasonic SDR-H80 digital video camera and after installing the software that came on the CD (VideoCam Suite) I keep getting a popup message when I login to the computer.

The message is: - System Error
The program can't start because MagCore.dll is missing from your computer. Try reinstalling the program to fix this problem.

Well I've tried doing that and it didn't help. I can run VideoCam Suite fine, I just keep getting the silly error each time I login.

My computer is 1 month old and is running Windows 7 Professional 64bit.

What is the problem and how can I fix it? Failing that, how can I supress the error?

share|improve this question

It sounds to me that the camera simply comes with a rubbish driver - like so many devices on the market.

In future the best thing you can do (but not always available) is to go to device manager, right click on the device and do install driver then manually locate it. The device will then be accessible to the system without requiring any special software.

But, to fix your problem, download Microsoft / Sysinternals Autoruns and simply look for the program that is starting with your system and disable it. I cannot be more help as there isn't enough information as to the program name.

To locate it, you can download Microsoft / Sysinternals Process Explorer and run it straight away without closing the box, then use the target tool/button to find the process that has launched the box, then you can disable it through Autoruns.

Hope this helps!

share|improve this answer
It's not a driver problem. The device doesn't come with drivers, just software for processing the video. – GiddyUpHorsey Jun 23 '10 at 8:39
up vote 0 down vote accepted

Solved the problem by determining what was. It is ArcSoft Connection Service. Downloading and installing the latest version of it stops the error.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .