Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I put the following lines to my _vimrc file in GVim on Windows XP:

set encoding=utf-8
set fileencodings=ucs-bom,utf-8

Then, ALT key changed its behavior in insert mode. Now, ALT key inserts accented characters when pressed with a letter key.

I have several mappings for ALT key in insert mode. But I need to use utf-8 as well. How can I enable utf-8 without changing the behavior of ALT key?

share|improve this question
up vote 4 down vote accepted

I found an acceptable solution:

I put my existing ALT key mappings after utf-8 settings. So my mappings are not broken.

share|improve this answer
    
You can mark your own answer as accepted, so people searching for this same question would know it already has a solution before even entering in this thread. – GmonC Jun 28 '10 at 1:02

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .