Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I had a disk error that rendered my Mac unbootable. I repaired it with Tech Tool 4, but now networking does not work.

Network Preferences reports that my Ethernet cable is unplugged. I know this is bogus because when I boot from an emergency partition, networking works correctly.

Furthermore, wireless networking is also broken, which I tested with a known-good Wi-Fi dongle.

Whenever I try to change Network Port Configurations by creating a New or Renaming an existing one,

example:

alt text

I get this message in the console:

Error - PortScanner - setDevice, device == nil!

Error - PortScanner - setDevice, device == nil!

In sets of two as shown.

When I try to invoke the Network Diagnostics app, it immediately crashes.

My first thought is to reinstall Tiger with the Archive and Install method so I don't have to reinstall all my applications but I have lost my Tiger installer disk.

My next thought is to buy Leopard for $107 on Amazon.

If there is any way I can just repair my Tiger install I would be happy to save that money, though. This is not my main machine and I am loathe to put more money into it.

How can I recover my network functionality?

UPDATE: I found my Tiger install disk and tried an Archive and Install. It failed with an unhelpful error message along the lines of "Can't install, try again". I tried again but had the same error. My guess is, some corrupt or missing file in my User folder is preventing migration.

I have a backup created with Super Duper that is a bit out of date but will startup the machine (with functional networking). I would love to just copy over the file(s) that got messed up but I don't even know where to look.

What is the likely location of the System files that would cause the aforementioned symptoms?

share|improve this question

2 Answers 2

I've seen lots of weird things crop up from disk corruption repaired by Tech Tool. Disk Warrior, however, has saved me from having to do a full backup restore time after time. Give it a shot.

Beyond using Disk Warrior, it looks like you have two options:

  1. Create a new user and see if networking works for the new user. This isolates where the problem file is. If the new user can access networking, then the problem is somewhere in your home folder. Most likely in the ~/Preferences folder. Otherwise see option 2

  2. Do a backup of your current data with SuperDuper and perform a clean install. Then migrate your data back from your backup sans networking preferences. The migration tool gives you an option for this.

share|improve this answer
up vote 1 down vote accepted

Running Disk Utility from the Tech Tool boot disk fixed the directory corruption that then allowed the Tiger installer to Archive and Install.

Next, I downloaded and ran the Tiger 10.4.11 Combo Updater, then ran Software Update. After that, I test-launched all of my important apps like the Adobe Creative Suite programs. Quite a few needed to pull down updates of their own, which only happens when you start them.

Result: Everything back with virtually no data loss. 40+ hours I will never get back.

Moral: Keep your OS Restore disks in a safe place. Pay the $27 to get Super Duper with scheduled backup feature. Run Tech Tool and Disk Utility regularly to detect and fix directory corruption before it becomes serious. Backup important files regularly and in an automated fashion.

Other moral: Be methodical. Document your progress. Share your results.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.